Bug 1076884 - [py3] highlight characters broken under py3
Summary: [py3] highlight characters broken under py3
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 20
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-16 08:11 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:56 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 23:58:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jiri Moskovcak 2014-03-16 08:11:08 UTC
Description of problem:

Trying to install an unknown package:

py2:
[root@localhost ~]# /usr/bin/python /usr/bin/dnf install omg-no
No package omg-no available.
Error: Nothing to do.

("omg-no" is highlighted)

py3:
[root@localhost ~]# /usr/bin/python3 /usr/bin/dnf install omg-no
Failed loading plugin: copr
Failed loading plugin: kickstart
No package b'\x1b[1m'omg-nob'\x1b(B\x1b[m' available.
Error: Nothing to do.

(garbled characters in the output)

Version-Release number of selected component (if applicable):
0.4.17-1.fc20 

How reproducible:
100%

Comment 1 Ales Kozumplik 2014-03-16 11:14:22 UTC
Looks like py3 compat issue, moving to Jan.

Comment 2 Honza Silhan 2014-03-26 15:32:24 UTC
Fixed in the upstream.

Comment 3 Fedora Update System 2014-05-02 08:32:26 UTC
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20

Comment 4 Fedora Update System 2014-05-02 21:04:58 UTC
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).

Comment 5 lnie 2014-05-20 06:23:45 UTC
Tested with dnf-0.5.1-1.fc20 and hawkey-0.4.14-1.fc20,the bug is gone

Comment 6 Fedora Update System 2014-05-28 12:10:16 UTC
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20

Comment 7 Fedora Update System 2014-05-28 23:50:14 UTC
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-05-31 23:58:49 UTC
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.