Bug 1076885 - shape insertion tool don't works
Summary: shape insertion tool don't works
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: scribus
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-16 08:17 UTC by Amich26
Modified: 2014-09-23 05:02 UTC (History)
5 users (show)

Fixed In Version: scribus-1.4.4-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 06:44:06 UTC


Attachments (Terms of Use)

Description Amich26 2014-03-16 08:17:51 UTC
Description of problem:

Actual results:

Users cannot choose other shapes than rectangles when inserting a new shape.

How reproducible: ALWAYS


Version-Release number of selected component (if applicable):

1.4.3-2.fc20


Additional info:

same bug that 1009979 CLOSED

Comment 1 Mario Ceresa 2014-08-28 07:27:04 UTC
Confirmed it still happens. It seems to be due to[1]:

QObject::connect : Incompatible sender/receiver arguments
        AutoformButtonGroup::FormSel(int,int,qreal*) --> ModeToolBar::SelShape(int,int,double*)

I changed the slots with the patch[2] and it works for me. Not sure if there is something else still lingering on...

The new source rpm is available here[3] and the koji build is here[4]. 

HTH,

Mario

[1] http://bugs.scribus.net/view.php?id=11738
[2] https://www.dropbox.com/s/15qlefyq4ysz776/scribus-1.4.3-to-double-fixed.patch?dl=0
[3] https://www.dropbox.com/s/tf7hbl4rgax09il/scribus-1.4.3-3.fc20.src.rpm?dl=0
[4] http://koji.fedoraproject.org/koji/taskinfo?taskID=7467066

Comment 2 Dan Horák 2014-08-28 09:44:20 UTC
(In reply to Mario Ceresa from comment #1)
> Confirmed it still happens. It seems to be due to[1]:
> 
> QObject::connect : Incompatible sender/receiver arguments
>         AutoformButtonGroup::FormSel(int,int,qreal*) -->
> ModeToolBar::SelShape(int,int,double*)
> 
> I changed the slots with the patch[2] and it works for me. Not sure if there
> is something else still lingering on...
> 
> The new source rpm is available here[3] and the koji build is here[4]. 
> 
> HTH,
> 
> Mario
> 
> [1] http://bugs.scribus.net/view.php?id=11738
> [2]
> https://www.dropbox.com/s/15qlefyq4ysz776/scribus-1.4.3-to-double-fixed.
> patch?dl=0
> [3]
> https://www.dropbox.com/s/tf7hbl4rgax09il/scribus-1.4.3-3.fc20.src.rpm?dl=0
> [4] http://koji.fedoraproject.org/koji/taskinfo?taskID=7467066

but your build failed on ARM, so it's not fixed correctly

Comment 3 Fedora Update System 2014-08-28 18:08:24 UTC
scribus-1.4.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/scribus-1.4.4-5.fc21

Comment 4 Fedora Update System 2014-08-28 18:08:33 UTC
scribus-1.4.4-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scribus-1.4.4-5.fc20

Comment 5 Fedora Update System 2014-08-28 18:08:48 UTC
scribus-1.4.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scribus-1.4.4-2.fc19

Comment 6 lnie 2014-08-29 04:14:05 UTC
scribus-1.4.4-5.fc20 works

Comment 7 Fedora Update System 2014-08-29 14:42:43 UTC
Package scribus-1.4.4-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scribus-1.4.4-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9896/scribus-1.4.4-5.fc21
then log in and leave karma (feedback).

Comment 8 Mario Ceresa 2014-08-29 15:20:31 UTC
(In reply to Dan Horák from comment #2)
> (In reply to Mario Ceresa from comment #1)
> > Confirmed it still happens. It seems to be due to[1]:
> > 
> > QObject::connect : Incompatible sender/receiver arguments
> >         AutoformButtonGroup::FormSel(int,int,qreal*) -->
> > ModeToolBar::SelShape(int,int,double*)
> > 
> > I changed the slots with the patch[2] and it works for me. Not sure if there
> > is something else still lingering on...
> > 
> > The new source rpm is available here[3] and the koji build is here[4]. 
> > 
> > HTH,
> > 
> > Mario
> > 
> > [1] http://bugs.scribus.net/view.php?id=11738
> > [2]
> > https://www.dropbox.com/s/15qlefyq4ysz776/scribus-1.4.3-to-double-fixed.
> > patch?dl=0
> > [3]
> > https://www.dropbox.com/s/tf7hbl4rgax09il/scribus-1.4.3-3.fc20.src.rpm?dl=0
> > [4] http://koji.fedoraproject.org/koji/taskinfo?taskID=7467066
> 
> but your build failed on ARM, so it's not fixed correctly

I'm sorry Dan, I really don't know enough about ARM platform to fix it :)

Comment 9 Fedora Update System 2014-09-02 06:44:06 UTC
scribus-1.4.4-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-09-09 22:13:27 UTC
scribus-1.4.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-09-23 05:02:28 UTC
scribus-1.4.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.