This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1077173 - IOError: [Errno 13] Permission denied: '/var/lib/dnf/groups.json'
IOError: [Errno 13] Permission denied: '/var/lib/dnf/groups.json'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-17 07:54 EDT by Tim Lauridsen
Modified: 2014-09-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.4.19-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 04:13:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lauridsen 2014-03-17 07:54:48 EDT
Description of problem:

Get an error when running group operations as non root

Version-Release number of selected component (if applicable):
0.4.18

How reproducible:
everytime

Steps to Reproduce:
1. dnf group list
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 74, in main
    return 1
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 116, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 245, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 171, in _store_persistent_data
    self._group_persistor.save()
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 55, in save
    with open(self.db, 'w') as db:
IOError: [Errno 13] Permission denied: '/var/lib/dnf/groups.json'

Expected results:
No traceback

Additional info:
Comment 1 Ales Kozumplik 2014-03-17 08:48:38 EDT
My bad, will fix it. Since it's only affecting non-root I wouldn't like to unpush https://admin.fedoraproject.org/updates/dnf-0.4.18-1.fc20 . But who knows how what the karma is giong to do.
Comment 2 Tim Lauridsen 2014-03-17 09:48:34 EDT
Fine with me, most users will use dnf as root.

It makes yumex-dnf blow up when closing, but i can live with that until a fix is released. :-)
Comment 3 Ales Kozumplik 2014-03-18 17:03:33 EDT
Fixed upstream by fc9f912.

Tim, if you don't want to wait for a proper release, you can try our CI repos: 

http://jenkins.cloud.fedoraproject.org/job/DNF/lastSuccessfulBuild/artifact/

we're experiencing various issues there lately but all should be fine soon and the builds there are all latest & greatest.
Comment 4 Tim Lauridsen 2014-03-19 01:48:10 EDT
Thanks, I will test it when an updated build pops up.

looking at the code it should fix the issue
Comment 5 Fedora Update System 2014-03-24 05:05:38 EDT
dnf-0.4.19-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.19-1.fc20
Comment 6 Fedora Update System 2014-03-25 04:13:15 EDT
dnf-0.4.19-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.