Bug 1077201 - keepalived not sending gratious arp after master/master
Summary: keepalived not sending gratious arp after master/master
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: keepalived
Version: 6.6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ryan O'Hara
QA Contact: Brandon Perkins
URL:
Whiteboard:
: 1110363 (view as bug list)
Depends On: 1052380
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-17 12:59 UTC by Lukas Herbolt
Modified: 2018-12-05 17:42 UTC (History)
3 users (show)

Fixed In Version: keepalived-1.2.13-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:12:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1510 normal SHIPPED_LIVE keepalived bug fix and enhancement update 2014-10-14 01:22:28 UTC

Description Lukas Herbolt 2014-03-17 12:59:34 UTC
Description of problem:
Normal: ServerA is holding VRRP managed address w.x.y.z, ServerB is backup for the address w.x.y.z. 

ServerA is suspended, so that ServerB transitions to master.
ServerA is resumed, now both servers are masters for a little while. Then ServerB goes into standby.

At this point the ARP table still points at ServerB for the w.x.y.z address, but ServerB doesn't answer to this address anymore. This is quite bad.

Version-Release number of selected component (if applicable):


How reproducible:
recover from failed/master to  master/backup

Steps to Reproduce:
1. setup master/backup environment
2. kill master 
3. wait until failover 
4. recover master

Actual results:
arp table is not cleared 

Expected results:
arp table cleared


Additional info:
It is fixed in following mainstream patch.
https://github.com/acassen/keepalived/commit/44a885325d1b825416bab7d2fe07cf8cd6c95ece

Comment 2 Ryan O'Hara 2014-03-17 16:09:50 UTC
Well aware of this. Will be fixed as part of rebase in RHEL6.6 (BZ#1052380).

Comment 11 Ryan O'Hara 2014-06-17 15:48:48 UTC
*** Bug 1110363 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2014-10-14 07:12:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1510.html


Note You need to log in before you can comment on or make changes to this bug.