Bug 107725 - init: open(/dev/pts/0): No such file or directory
init: open(/dev/pts/0): No such file or directory
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: rhgb (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 10:01 EDT by Jonathan Kamens
Modified: 2007-04-18 12:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 03:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-10-22 10:01:37 EDT
SysVinit-2.85-5 is logging "init: open(/dev/pts/0): No such file or directory" 
every time mgetty exits restarts after I receive a fax.  I think this started 
recently.  Why is it logging this and how to I make it stop?

Note that I've got devpts mounted on /dev/pts, and indeed /dev/pts/0 doesn't 
exist.
Comment 1 Bill Nottingham 2003-10-22 11:12:22 EDT
'exits restarts'?

When do you have mgetty started?
Comment 2 Jonathan Kamens 2003-10-22 11:21:41 EDT
Mgetty runs from inittab.  It exits, and init restarts it, every time someone 
dials into my modem line (when the call or fax is finished).
Comment 3 Bill Nottingham 2003-10-22 11:28:39 EDT
I'm assuming you booted with rhgb.

Did rhgb shut down oddly at all?
Comment 4 Jonathan Kamens 2003-10-22 11:59:29 EDT
I didn't see anything odd with rhgb the last time I booted, but if you'd like, 
I'll reboot again and see what comes up.  Can you be more specific about what I 
should look for?
Comment 5 Bill Nottingham 2003-10-22 12:09:00 EDT
Anything that would imply it terminated abnormally.

Jonathan, we do revert init's console at the end of all exit paths in rhgb, right?
Comment 6 Bill Nottingham 2003-10-22 12:24:45 EDT
Hm, actually... does this happen *every* time mgetty restarts, or only the first
time?
Comment 7 Bill Nottingham 2003-10-22 12:26:42 EDT
Does it go away if you add:

[ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --quit

to the end of /etc/rc?
Comment 8 Jonathan Kamens 2003-10-22 13:04:59 EDT
Every time.
Comment 9 Jonathan Kamens 2003-11-20 22:59:43 EST
That line is already at the end of /etc/rc in initscripts-7.42.1-1,
which I installed earlier today, and the problem is still occurring
after a reboot.
Comment 10 Bill Nottingham 2003-11-20 23:16:30 EST
Argh, let me guess what happens... sleep 1 (or sleep 2) at the end of
/etc/rc will fix it, won't it...?
Comment 11 Jonathan Kamens 2003-11-20 23:26:35 EST
Putting "sleep 2" at the end of /etc/rc did not solve the problem.
Comment 12 Orion Poplawski 2004-04-23 11:15:08 EDT
Any progress on this?  I see this on our FC1 machines as well.
Comment 13 Gilles Detillieux 2004-06-24 12:58:20 EDT
I see this error on my FC1 and FC2 machines too.  They all use rhgb. 
They're all updated nightly via yum, so they all have the rhgb-client
--quit call at the end of /etc/rc.  Should I stop using rhgb to get
rid of these messages?  Fortunately, I rarely get more than a half
dozen of these when I boot, and usually only one or two, but I still
don't want to get in the habit of just ignoring warning messages, so
I'd like to find a way to get rid of these (hopefully by actually
fixing the problem).
Comment 14 Bill Nottingham 2004-06-28 16:30:12 EDT
Basically, /dev/pts/0 is what init opens as the console for the
messages seen in 'details' mode when used with rhgb. rhgb is supposed
to reset init's definition of the console when it exits.

So, it *appears* init isn't getting reset right for some reason.
Comment 15 Jeff Moe (jebba) 2004-07-22 22:33:05 EDT
I see this in FC1. System has some winmodem that isn't setup/used.
Using rhgb (custom one though).
Comment 16 Brian Henning 2004-11-02 09:03:22 EST
Me too..  NOT using rhgb; FC2.  The problem started recently and 
coincided either with disabling rhgb (by removing the rhgb switch 
from the kernel parameters in grub.conf) or with attempting to start 
using mgetty/pppd to allow dial-in access.  Those two changes were 
fairly close together last week, so I'm not sure which (if either) is 
more closely coincidental with the new open(/dev/pts/0) problem.
Comment 17 Brian Henning 2004-11-02 09:15:04 EST
Sorry for the two rapid-fire posts..  Anyhow, I just reexamined my 
logs, and the open(/dev/pts/0): No such file... issue did exist 
before the move away from rhgb and the addition of mgetty/pppd; it 
simply became much more pronounced (from about 3 messages/day to 
>1000 messages/day) after adding the mgetty respawn to inittab.  
It DOES appear to be tied, to some extent, to the respawning of 
mgetty; if the modem is turned off (which causes mgetty to respawn 
every few seconds when init chats fail), one of those messages 
accompanies each set of mgetty errors.  
I hope this info is helpful..  
Comment 18 Bill Nottingham 2006-08-07 22:01:59 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 19 Jonathan Kamens 2006-09-03 03:35:49 EDT
Can't duplicate any longer.

Note You need to log in before you can comment on or make changes to this bug.