Bug 107731 - gdialog doesn't handle spaces
gdialog doesn't handle spaces
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 11:04 EDT by Peter Åstrand
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-28 15:00:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Åstrand 2003-10-22 11:04:50 EDT
Description of problem:
The gdialog compatibility wrapper for zenity doesn't handle arguments with spaces. 

Version-Release number of selected component (if applicable):
gnome-utils2.4.0-1

Here's an example that gives a very strange result:

gdialog --title "My title" --radiolist "My list" 400 500 5 1 "First choice" on 2
"Second choice" off
Comment 1 Peter Åstrand 2003-10-28 04:58:12 EST
I've created a patch now, see http://bugzilla.gnome.org/show_bug.cgi?id=125337. 
Comment 2 Peter Åstrand 2003-10-28 04:59:38 EST
Very much related: http://bugzilla.gnome.org/show_bug.cgi?id=125672. Please apply...
Comment 3 Jef Spaleta 2004-02-28 15:00:25 EST
I'm going to close this specific bugreport as upstream, since it seems
the upstream developers are incorporating the patches.

If you would like to see these patches used in a possible update to
FC1.  Please open a new bug against FC1 with patches against the FC1
version of the source code attached. 

I know it might seem redundant to submit patches both upstream and
here in the distribution level bugzilla. But it's a good idea for
Fedora users to be able to find and review the patches specifically on
Fedora systems, to make a stronger case for incorporating the patches
into a possible update package.  This of course doesn't garuntee the
package maintainer will feel its worth doing, but community review and
confirmation that the patches work for fedora specifically, won't hurt
the chances.


Note You need to log in before you can comment on or make changes to this bug.