Bug 107736 - does not handle http://ftp.redhat.com/pub/
does not handle http://ftp.redhat.com/pub/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
: EasyFix, Patch
Depends On:
Blocks: EasyFix-Tracker
  Show dependency treegraph
 
Reported: 2003-10-22 11:26 EDT by Gene Czarcinski
Modified: 2013-04-02 00:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 14:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
more fixes from Brian for http (709 bytes, patch)
2003-10-23 13:59 EDT, Gene Czarcinski
no flags Details | Diff
gftp-rfc2068-chunk-transfer-2.patch (9.81 KB, patch)
2003-11-04 11:04 EST, Gene Czarcinski
no flags Details | Diff
gftp-rfc2068-chunk-transfers-3.patch (1.03 KB, patch)
2003-11-04 11:05 EST, Gene Czarcinski
no flags Details | Diff

  None (edit)
Description Gene Czarcinski 2003-10-22 11:26:59 EDT
Description of problem:
Everything in gftp implies that it can handle http as well as ftp.  However, it
does not seem to be able to handle http://ftp.redhat.com/pub/redhat/linux/ 

The "text" is downloaded but not interpreted whereas lftp handles it nicely.
Comment 1 Gene Czarcinski 2003-10-22 13:49:12 EDT
OK, I sent a message to the gftp upstream maintainer and got the following:

What version of gftp are you using? If you aren't using 2.0.15, I would
suggest upgrading. In all versions of gftp < 2.0.15, the HTTP protocol had a
lot of problems. Using my latest CVS version, I was able to connect to that
URL and browse the directories and download files. I have not changed
anything with HTTP in CVS since 2.0.15 was released.

Brian

I get 2.0.15 and rebuilt the rpm.  With 2.0.15, handling of http is much, much
better ... it actually handles it.  However, it is not perfect and I have
reported this to him.  It now sees the numeric directories under
/pub/redhat/linux but not the non-numeric ones (??).
Comment 2 Gene Czarcinski 2003-10-23 13:58:11 EDT
I got the following from Brian.  This patch fixes things a bit more but still
has some problems when dealing with moving up and down trees on ftp.redhat.com.
 I will attach the patch he supplied.

I have attached a patch that fixes this. I'm hoping to find time to get a few
remaining issues fixed by this weekend so I can release 2.0.16. This will be
a bugfix only release. A tarball of my latest code is online at
http://www.gftp.org/gftp-test.tar.bz2.

Brian


On Wed, Oct 22, 2003 at 01:45:03PM -0400, Gene C. wrote:
> On Wednesday 22 October 2003 13:03, Brian Masney wrote:
> > What version of gftp are you using? If you aren't using 2.0.15, I would
> > suggest upgrading. In all versions of gftp < 2.0.15, the HTTP protocol had
> > a lot of problems. Using my latest CVS version, I was able to connect to
> > that URL and browse the directories and download files. I have not changed
> > anything with HTTP in CVS since 2.0.15 was released.
> 
> OK, I gave 2.0.15 a try and it does improve things a lot.  However, it is 
> still not quite correct.  For example, at 
> http://ftp.redhat.com/pub/redhat/linux I only see the the "numbered" 
> directories and not the beta, code, enterprise, preview, rawhide, or updates 
> directories (which are seen by lftp and the same as if accessed by 
> ftp://ftp.redhat.com/pub/redhat/linux/
> -- 
> Gene Czarcinski
Comment 3 Gene Czarcinski 2003-10-23 13:59:31 EDT
Created attachment 95437 [details]
more fixes from Brian for http
Comment 4 Gene Czarcinski 2003-11-04 11:02:53 EST
More from Brian Masey:

 Here are two patches that will fix this issue that you are having.
You can
apply these to the gftp source that I had you download the other day.
Change
to the gftp-2.0.16pre0/lib directory and type the following commands:

patch -p0 < gftp-rfc2068-chunk-transfers-2.patch
patch -p0 < gftp-rfc2068-chunk-transfers-3.patch

and then recompile.

I will attach patches.

http access now works "pretty" well but still has some problems.
Comment 5 Gene Czarcinski 2003-11-04 11:04:28 EST
Created attachment 95710 [details]
gftp-rfc2068-chunk-transfer-2.patch
Comment 6 Gene Czarcinski 2003-11-04 11:05:36 EST
Created attachment 95711 [details]
gftp-rfc2068-chunk-transfers-3.patch
Comment 7 Gene Czarcinski 2003-11-11 07:35:36 EST
Upstream (Brian Masney) appear to have fixed http handling so it now
works.  gftp 2.0.16 has been released and incorporates the attached
patches.

I encourage the release of an errata for gftp 2.0.16
Comment 8 Gene Czarcinski 2003-11-19 17:24:52 EST
Triage->Easyfix (at least IMHO)

Red Hat does not patch this package ... just needs to be download from
upstream, change the version in the spec file, build rpms, and place
in updates/testing.

Beside http://... protocol now working, there are some reports (on
fedora-list) of the shipped gftp hanging/crashing.
Comment 9 Gene Czarcinski 2003-11-20 15:54:42 EST
I have bult rpms which can be used for testing:

ftp://czarc.net/pub/gftp-2.0.16-0.gc1.i386.rpm
ftp://czarc.net/pub/gftp-2.0.16-0.gc1.src.rpm
Comment 10 Miloslav Trmac 2004-02-17 13:42:35 EST
gftp-2.0.16 is now in rawhide, can this be closed?
Comment 11 Gene Czarcinski 2004-02-17 14:39:12 EST
Yes, closing

Note You need to log in before you can comment on or make changes to this bug.