Bug 10774 - XFree86, xscreensaver can't both be upgraded from rawhide
XFree86, xscreensaver can't both be upgraded from rawhide
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-12 23:31 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-14 18:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-04-12 23:31:08 EDT
I have xscreensaver-3.24-1 and Mesa-3.2-2 installed.  When I try to
upgrade to the XFree86 4.0 Rawhide packages, I get:

error: failed dependencies:
        libGLU.so.1 is needed by xscreensaver-3.24-1

I don't quite understand this, since Mesa provides thelibGLU.so.1 that
xscreensaver wants, and I'm not upgrading Mesa, so that library should
remain after the XFree86 4.0 upgrade.  Unlexx the new XFree86 RPM are
somehow configured to supersede the Mesa RPM or something.

In short, either XFree86 or xscreensaver has a problem which prevents
both of them from being upgraded together from Rawhide.
Comment 1 SB 2000-05-14 18:51:59 EDT
Mesa is included with XFree86 4.0 in the XFree86-libs-4.0-0.8.i386.rpm package
including libGLU.so.1 so remove your Mesa package and install the XFree86-libs
and XFree86 stuff then install xscreensaver.  Upgrade any packages which claim
to depend on Mesa if they are vital, but it would probably be safe to uninstall
Mesa with --nodeps after trying it without the flag to see what needs it.

Hope that helped,

-Stan Bubrouski
Comment 2 Bill Nottingham 2000-07-03 18:47:59 EDT
Mesa is a separate package again now, as of the 0.20+ XFree86-4.0
RPMs.

Note You need to log in before you can comment on or make changes to this bug.