Bug 10774 - XFree86, xscreensaver can't both be upgraded from rawhide
Summary: XFree86, xscreensaver can't both be upgraded from rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-13 03:31 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-14 22:51:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-04-13 03:31:08 UTC
I have xscreensaver-3.24-1 and Mesa-3.2-2 installed.  When I try to
upgrade to the XFree86 4.0 Rawhide packages, I get:

error: failed dependencies:
        libGLU.so.1 is needed by xscreensaver-3.24-1

I don't quite understand this, since Mesa provides thelibGLU.so.1 that
xscreensaver wants, and I'm not upgrading Mesa, so that library should
remain after the XFree86 4.0 upgrade.  Unlexx the new XFree86 RPM are
somehow configured to supersede the Mesa RPM or something.

In short, either XFree86 or xscreensaver has a problem which prevents
both of them from being upgraded together from Rawhide.

Comment 1 SB 2000-05-14 22:51:59 UTC
Mesa is included with XFree86 4.0 in the XFree86-libs-4.0-0.8.i386.rpm package
including libGLU.so.1 so remove your Mesa package and install the XFree86-libs
and XFree86 stuff then install xscreensaver.  Upgrade any packages which claim
to depend on Mesa if they are vital, but it would probably be safe to uninstall
Mesa with --nodeps after trying it without the flag to see what needs it.

Hope that helped,

-Stan Bubrouski

Comment 2 Bill Nottingham 2000-07-03 22:47:59 UTC
Mesa is a separate package again now, as of the 0.20+ XFree86-4.0
RPMs.


Note You need to log in before you can comment on or make changes to this bug.