Bug 1077410 - No documentation or not at the right place.
Summary: No documentation or not at the right place.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt-creator
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-17 22:57 UTC by Eric
Modified: 2014-08-17 09:31 UTC (History)
7 users (show)

Fixed In Version: qt-creator-3.1.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 15:31:55 UTC


Attachments (Terms of Use)

Description Eric 2014-03-17 22:57:41 UTC
Description of problem:
By default, qt-creator looks for the help at this url:

qthelp://org.qt-project.qtcreator.301/doc/index.html

But fails to find it.

Version-Release number of selected component (if applicable):
qt-creator-3.0.1-1.fc20.x86_64

How reproducible:
Always.

Comment 1 Sandro Mani 2014-03-17 23:06:02 UTC
Does installing qt-doc fix the issue?

Comment 2 Eric 2014-03-25 22:23:50 UTC
Nope. Sorry for not mentioning which docs were installed:

$ rpm -qa qt\*doc\* | sort
qt5-qtbase-doc-5.2.1-6.fc20.noarch
qt5-qtdoc-5.2.1-1.fc20.noarch
qt-doc-4.8.5-15.fc20.noarch

Comment 3 Fedora Update System 2014-07-29 13:18:14 UTC
qt-creator-3.1.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt-creator-3.1.2-2.fc20

Comment 4 Fedora Update System 2014-07-29 15:09:36 UTC
qt-creator-3.1.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt-creator-3.1.2-2.fc19

Comment 5 Fedora Update System 2014-07-30 06:59:05 UTC
Package qt-creator-3.1.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-creator-3.1.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8981/qt-creator-3.1.2-2.fc20
then log in and leave karma (feedback).

Comment 6 Brallan Jesús Aguilar Rivera 2014-07-31 06:17:33 UTC
When I start Qt Creator and go to Help menu, appear a message: 

The page could not be found!

Error loading: qthelp://org.qt-project.qtcreator.312/doc/index.html

Comment 7 Sandro Mani 2014-07-31 09:31:49 UTC
Did you install qt-creator-doc?

Comment 8 Brallan Jesús Aguilar Rivera 2014-07-31 19:17:44 UTC
(In reply to Sandro Mani from comment #7)
> Did you install qt-creator-doc?

Er, where can I find it?

Comment 9 Sandro Mani 2014-07-31 19:35:42 UTC
If you are running F20, it is in updates-testing, see comment 5. If you are running F19, it will land in updates-testing soon, in the meantime the build is here [1]. If you are running rawhide and F21 it should be in the default repo.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=548925

Comment 10 Brallan Jesús Aguilar Rivera 2014-07-31 19:41:53 UTC
(In reply to Sandro Mani from comment #9)
> If you are running F20, it is in updates-testing, see comment 5. If you are
> running F19, it will land in updates-testing soon, in the meantime the build
> is here [1]. If you are running rawhide and F21 it should be in the default
> repo.
> 
> [1] http://koji.fedoraproject.org/koji/buildinfo?buildID=548925

I have F20, and the steps on comment #5 doesn't install qt-creator-doc

Comment 11 Sandro Mani 2014-07-31 19:50:43 UTC
qt-creator does not depend on qt-creator-doc, so updating qt-creator does not automatically install the latter. So you must install it:

su -c 'yum install --enablerepo=updates-testing qt-creator-doc-3.1.2-2.fc20'

Comment 12 Brallan Jesús Aguilar Rivera 2014-07-31 20:03:26 UTC
Perfect, it works! Although I believe that qt-creator-doc is essential to solve this bug. Those that want to check if this bug was solved should know that qt-creator-doc must be installed.

Thanks a lot :)

Comment 13 Sandro Mani 2014-07-31 20:21:12 UTC
Well actually it is written in the update description, see [1] ;)

https://admin.fedoraproject.org/updates/qt-creator-3.1.2-2.fc20

Comment 14 Fedora Update System 2014-08-07 15:31:55 UTC
qt-creator-3.1.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2014-08-07 15:33:55 UTC
qt-creator-3.1.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Paul Campbell 2014-08-17 02:32:27 UTC
I encountered the same problem on 2014-08-16; because of this bug report, I downloaded qt-creator on 08-15 which seems to have fixed problem.

Shouldn't there be a dependency on qt-creator-doc for qt-creator?
It might prevent future reports.

Comment 17 Sandro Mani 2014-08-17 09:31:23 UTC
I realize that this is not really optimal, however having dependencies on -doc packages is frowned upon, since they are not strictly required for runtime. Also, it is kind of consistent with how the other qt packages are structured: by installing qt-devel, you don't automatically get qt-doc and hence the corresponding documentation in the qt-creator help browser. You must install it manually.


Note You need to log in before you can comment on or make changes to this bug.