Bug 107749 - Installer will not load mptscsih module after aic7xxx is loaded
Installer will not load mptscsih module after aic7xxx is loaded
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Don Howard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 13:11 EDT by Nate Golnik
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 19:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Golnik 2003-10-22 13:11:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
Attempting to install QU2 on a Dell 1750 with an LSI MPT scsi controller for the
onboard disks and a Adaptec 39160 for connecting to a Dell Powervault 220.

During the install aic7xxx loads followed by mptscsih.  Mptscsih fails 
out with the following:

mptbase:  Initiating ioc0 bringup
     ioc0: ERROR Doorbell Ack timeout (2)
     ioc0: ERROR Doorbell Ack timeout (2)
     ioc0: ERROR Diagnostic reset failed (102h)
     ioc0: Not Ready Warning
     WARNING: ioc0 did not initalize properly! (-1)
Repeats for ioc1
mptbase: 2 mpt adapters found, 0 installed.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take a dell 1750 add in an adaptec 39160 
2. Start QU2 install

    

Actual Results:  mtpscsih fails to load.  0 disks will be found.

Expected Results:  mptscsih should load and bring in /dev/sda and /dev/sdb

Additional info:

removing the adaptec controller will allow you to do an install.
After the install the e.24 kernel does not have an issue with both the adaptec
and LSI card being in the machine.
Comment 1 Jason Baron 2003-12-04 17:16:00 EST
Maybe the latest U3 bits address this issue? cc'ing Jeremy and Tom
Coughlan...
Comment 2 Michael Stefaniuc 2004-04-08 15:14:37 EDT
AS2.1-U3 fails with the same error on a Dell PE1750
Comment 3 Jason Baron 2004-04-08 15:17:59 EDT
We updated the mpt fusion driver to version 2.05.11.03 in U4, can we
give that a try?
Comment 4 Michael Stefaniuc 2004-04-08 15:45:50 EDT
I can give U4 a try but that's not out yet (i'll search for a beta
version of U4).
Regarding U3: the trick with tacking out the Adaptec controller didn't
worked (well it worked halfway): the mptscsih driver was successfully
loaded and recognized sda and sdb. After fetching the ks.cfg file the
box loaded the adaptec driver (there's no mention of it anywhere) and
anaconda bombed out with: "Running on a live system. This is a very
stupid thing to do!" which seems to mean no HD's where found.
U2 works flawlessly (but only with the adaptec card removed)
regardless of the installer trying to load the adaptec driver too.
Comment 5 Rob Kearey 2004-12-11 05:14:11 EST
Encountered the same issue with U5 and a similar 1750. Removing the
Adaptec card seems to have fixed the problem. Server is installing as
expected. 
Comment 6 Rob Kearey 2004-12-22 00:09:06 EST
Server installed. Added the Adaptec card back. Dell Powervault PV122t not picked
up by the driver, needed to do the following to get the tape device and
autoloader generic device loaded:

echo "scsi remove-single-device 2 0 6 1" > /proc/scsi/scsi
echo "scsi remove-single-device 2 0 6 0" > /proc/scsi/scsi
rmmod st
rmmod sg
echo "scsi add-single-device 2 0 6 1" > /proc/scsi/scsi
echo "scsi add-single-device 2 0 6 0" > /proc/scsi/scsi
modprobe sg
modprobe st

Comment 7 Don Howard 2006-09-11 19:37:38 EDT
This is an old report and will now be closed due to inactivity.  If this is
still an issue with current RHEL2.1 kernels, please re-open the ticket with
updated info.

Note You need to log in before you can comment on or make changes to this bug.