Bug 10775 - rpm upgrade nearly blew away my RPM database!
rpm upgrade nearly blew away my RPM database!
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 11361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-12 23:36 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-13 04:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-04-12 23:36:46 EDT
I had rpm-3.0.4-0.38 and rpm-build-3.0.4-0.48 installed.  I downloaded
a whole bunch of rawhide packages to upgrade, including rpm-3.1-0.3
and rpm-build-3.1-0.3  I upgraded them.  When i tried to do "rpm -q
xscreensaver" afterwards, I got:

  rpmdb: /var/lib/rpm/__db_mpool.share: No such file or directory
  *** db2 db_appinit rc -1 No such file or directory
  *** FIXME: <message about how to convert db>

  --> Please run "rpm --rebuilddb" as root to convert your database from
      db1 to db2 on-disk format.

  *** db0open: /var/lib/rpm/nameindex.rpm
  *** db0open: /var/lib/rpm/fileindex.rpm
  *** db0open: /var/lib/rpm/groupindex.rpm
  *** db0open: /var/lib/rpm/requiredby.rpm
  *** db0open: /var/lib/rpm/providesindex.rpm
  *** db0open: /var/lib/rpm/conflictsindex.rpm
  *** db0open: /var/lib/rpm/triggerindex.rpm
  xscreensaver-3.24-1

I ran "rpm --rebuilddb", and I got:

  *** rpmdbRebuild: filterdbdups 0 preferdb 3
  rpmdb: /var/lib/rpm/__db_mpool.share: No such file or directory
  *** db2 db_appinit rc -1 No such file or directory
  *** FIXME: <message about how to convert db>

  --> Please run "rpm --rebuilddb" as root to convert your database from
      db1 to db2 on-disk format.

  *** db0open: /var/lib/rpm/nameindex.rpm
  *** db2open: nameindex.rpm
  *** db2open: fileindex.rpm
  *** db2open: groupindex.rpm
  *** db2open: requiredby.rpm
  *** db2open: providesindex.rpm
  *** db2open: conflictsindex.rpm
  *** db2open: triggerindex.rpm
  error: failed to remove directory /var/lib/rpmrebuilddb.7915: Directory
not empty

I then attempted to run "rpm -q xscreensaver" again, and I got:

  rpmdb: /var/lib/rpm/__db_mpool.share: No such file or directory
  *** db2 db_appinit rc -1 No such file or directory
  *** FIXME: <message about how to convert db>

  --> Please run "rpm --rebuilddb" as root to convert your database from
      db1 to db2 on-disk format.

  cannot open file /var/lib/rpm/nameindex.rpm: Invalid argument
  rpmQuery: rpmdbOpen() failed

I managed to recover by using "rpm -U --force" to go back to the old
rpm packages and then running "rpm --rebuilddb".  At least, I *hope*
I'm now recovered, as opposed to with a corrupt database just waiting
to screw me over later.
Comment 1 Jeff Johnson 2000-04-13 04:23:59 EDT
rpm-3.1 is under development, and Raw Hide is caveat emptor.
Comment 2 Jonathan Kamens 2000-04-13 09:18:59 EDT
1) It seems to me that even if rpm-3.1 is still under development, this is still
a bug that needs to be fixed, so why not leave it in the database so it can be
tracked and not forgotten?

2) I realize that Raw Hide is caveat emptor, but some of us believe that we're
doing y'all a favor by installing Raw Hide packages so that they get tested
widely and quickly.  I know that I've found a large number of bugs for you in
Raw Hide packages, and in numerous cases I was the first person to report them.
Therefore, since it is beneficial for people like me to be running Raw Hide
packages, I think y'all should at least make a minimal effort to keep the
passages useable.  I don't mind pretty rough edges, and indeed this qualifies as
just such a rough edge since I was able to recover from it, but I think that if
my RPM database had really been blown away completely, that would have been a
bit more of a "rough edge" than should reasonably appear in a released Raw Hide
package.
Comment 3 Jeff Johnson 2000-04-13 11:09:59 EDT
Several points:

1) The "bug" has been fixed, and several more have been introduced. Leaving
open bug reports for software under "active development" is misleading and
confusing for everyone involved.

2) The "passages were usable" or you would have blown away your database.
"Rough edges" wrto rpm means that you risk having your database blown away
by running bleeding edge software.

3) Raw Hide is caveat emptor. Period. Immediately after a release, Raw Hide
is often broken in major and unpredictable ways. Period.
Comment 4 Jeff Johnson 2000-05-11 08:06:59 EDT
*** Bug 11361 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.