Bug 1077515 - cpu hot plug is not seen on guest, when done after cpu hot unplug
Summary: cpu hot plug is not seen on guest, when done after cpu hot unplug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Roy Golan
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
: 1077539 (view as bug list)
Depends On:
Blocks: 833102
TreeView+ depends on / blocked
 
Reported: 2014-03-18 07:07 UTC by Ilanit Stein
Modified: 2014-06-12 14:05 UTC (History)
14 users (show)

Fixed In Version: org.ovirt.engine-root-3.4.0-18
Doc Type: Known Issue
Doc Text:
note this "known issue" is only for previous 3.4 beta builds. In 3.4 GA the unplug should not be enabled and hence the below doesn't apply: It was previously possible to attempt to unplug CPUs from running VMs, even though QEMU doesn't support it. The unplug feature has been removed from 3.4 and no option offering it appears in the GUI. Only hotplug is supported.
Clone Of:
Environment:
Last Closed: 2014-06-12 14:05:46 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25898 None None None Never
oVirt gerrit 25899 None None None Never
oVirt gerrit 26534 None None None Never

Description Ilanit Stein 2014-03-18 07:07:04 UTC
Description of problem:

After cpu unplug, run cpu hot plug do not effect the number on cpus, seen in the VM.
The hotplug was done both via UI and REST, and in response there was an event that VM was updated. lscpu in the VM showed the cpu number did not increase, as expected.

The VM is installed with rhel6.5 (no guest agent installed).

For example, move from 4 to 2 cpus, then try to move from 2 to 4 cpus.
  

Version-Release number of selected component (if applicable):
av2

Comment 1 Ilanit Stein 2014-03-18 07:15:03 UTC
In UI, after cpu hotplug (2->4), the number of cpus is updated in the edit VM window, as expected (to 4).

Comment 2 Ilanit Stein 2014-03-18 07:55:20 UTC
engine.log:
2014-03-17 13:49:40,956 INFO  [org.ovirt.engine.core.bll.HotSetNumberOfCpusCommand] (ajp-/127.0.0.1:8702-9) [1fc1a565] Running command: HotSetNumberOfCpusCommand internal: true. Entities affected :  ID: 45ea6762-d757-4878-a582-0fed0134da21 Type: VM
2014-03-17 13:49:40,958 INFO  [org.ovirt.engine.core.vdsbroker.SetNumberOfCpusVDSCommand] (ajp-/127.0.0.1:8702-9) [1fc1a565] START, SetNumberOfCpusVDSCommand(HostName = lilach-vdsb.tlv.redhat.com, HostId = e265dd29-6f62-4bb2-8474-168e4950f3db, vmId=45ea6762-d757-4878-a582-0fed0134da21), log id: 7d9c017f
2014-03-17 13:49:40,976 ERROR [org.ovirt.engine.core.vdsbroker.SetNumberOfCpusVDSCommand] (ajp-/127.0.0.1:8702-9) [1fc1a565] Command SetNumberOfCpusVDSCommand(HostName = lilach-vdsb.tlv.redhat.com, HostId = e265dd29-6f62-4bb2-8474-168e4950f3db, vmId=45ea6762-d757-4878-a582-0fed0134da21) execution failed. Exception: VDSErrorException: VDSGenericException: VDSErrorException: Failed in vdscommand to SetNumberOfCpusVDS, error = Operation not supported: qemu didn't unplug the vCPUs properly
2014-03-17 13:49:40,976 INFO  [org.ovirt.engine.core.vdsbroker.SetNumberOfCpusVDSCommand] (ajp-/127.0.0.1:8702-9) [1fc1a565] FINISH, SetNumberOfCpusVDSCommand, log id: 7d9c017f
2014-03-17 13:49:40,987 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-9) [1fc1a565] Correlation ID: 1fc1a565, Call Stack: null, Custom Event ID: -1, Message: Faild to hot set number of CPUS to VM rhel. Underlying error message: Operation not supported: qemu didn't unplug the vCPUs properly
2014-03-17 13:49:41,008 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-9) [1fc1a565] Correlation ID: 289b45fd, Job ID: f19a5097-f49c-4522-bbe8-7749925f1140, Call Stack: null, Custom Event ID: -1, Message: VM rhel configuration was updated by admin.

Comment 3 Roy Golan 2014-03-19 08:50:31 UTC
going to block unplug CPU till libvirt fixes Bug 1017858

Comment 4 Michal Skrivanek 2014-03-24 09:12:52 UTC
*** Bug 1077539 has been marked as a duplicate of this bug. ***

Comment 5 Michal Skrivanek 2014-04-14 11:42:44 UTC
roy - review 25898 is for this bug (then please merge&backport) or tracing separately (where?)

otherwise the block unplug is merged

Comment 6 Roy Golan 2014-05-07 09:07:10 UTC
25898 is for allowing to overcommit the number of cpus. I don't think its tracked by a bz. I'll open one if needed.

Comment 8 Ilanit Stein 2014-05-18 09:00:08 UTC
Verified on av9.1.
cpu Hot unplug trial fail on event:
"Faild to hot set number of CPUS to VM rhel6. Underlying error message: Hot un-plugging a CPU is not supported for cluster version 3.4 and architecture x86_64." 

Also on a rhel6.5 guest, verify using lscpu that cpu number not changed, following the unplug trial.

Comment 9 Itamar Heim 2014-06-12 14:05:46 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.