Bug 107759 - kcontrol has badly translated items
kcontrol has badly translated items
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Seth Nickell
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 15:15 EDT by Richard Allen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-08 15:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kcontrol running in the Icelandic locale (160.94 KB, image/png)
2003-10-22 15:16 EDT, Richard Allen
no flags Details

  None (edit)
Description Richard Allen 2003-10-22 15:15:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030702

Description of problem:
Im a member of the KDE i18n team (for Icelandic) and the translations for
Icelandic look wierd.
Im pretty sure that the translations are up 2 date in the KDE cvs but things
still look strange.   Im attaching a screenshot.

Its the modules that are open in the screenshot that have the bad names.
Looks like some UTF-8 vs. ISO8859-1 conflict.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select Icelandic
2. Open the KDE control Center (kcontrol)
3. Look at the strange characters
    

Additional info:

Im using severn, test3 fully updated via apt from rawhide.
Comment 1 Richard Allen 2003-10-22 15:16:55 EDT
Created attachment 95394 [details]
kcontrol running in the Icelandic locale
Comment 2 Richard Allen 2003-10-22 15:52:10 EDT
I retrived desktop_kdebase.po from the KDE_3_1_BRANCH in CVS.  Its fully translated:

[ra@proxy messages]$ msgfmt -v -o /dev/null kdebase/desktop_kdebase.po 
1205 translated messages.

I replaced /usr/share/locale/is/LC_MESSAGES/desktop_kdebase.mo with a .mo file I
generated from that .po file, but it didnt change anything.  I still have
untranslated items in kcontrol and those two bad strings.

Im totaly baffled.

Comment 3 Richard Allen 2003-10-25 13:57:59 EDT
After much investigating, the problem has been found.  Turns out that
translations from the .po files are merged into .desktop files in /var/lib/menu/kde
The files in question for me, and this bug report are
/var/lib/menu/kde/Applications/Settings/LookNFeel.   Im told the process for
creating the files in as such.  We translators commit our .po files into the CVS
and once a day the CVS server automaticly runs a merging process to create the
.desktop files.  Im told this process fails from time to time.  This seems to be
the case on the day Red Hat checked out the i18n files from the KDE cvs.

So basicly all you need to do is to check the files out again and roll new
kde-i18n packages.   It's likely that more languages than just Icelandic are
broken so this action would possibly fix more than just my problems.  Also,
there has been quite a lot of activity in the i18n section of the KDE cvs so
redoing the packages enhance the translations for all the locales.
Comment 4 Richard Allen 2003-10-26 17:45:54 EST
[root@xo root]# rpm -qf /usr/share/desktop-menu-files/KDE-LookNFeel.directory
redhat-menus-0.40-1

Looks like KDE was a bad choice and redhat-menus is the way to go.
Comment 5 Richard Allen 2004-04-19 13:28:40 EDT
Fixed in KDE 3.2.1 and 3.2.2 in Rawhide.
You can close this one.

Note You need to log in before you can comment on or make changes to this bug.