Bug 1077716 - FlightCrew bundles zipios++
FlightCrew bundles zipios++
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: FlightCrew (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-03-18 09:25 EDT by Ville Skyttä
Modified: 2014-03-19 06:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: FlightCrew-0.7.2-10.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-19 06:57:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Diff between separate and FlightCrew zipios++ (4.42 KB, patch)
2014-03-18 10:38 EDT, Ville Skyttä
no flags Details | Diff
use system zipios - preliminary fix (209.70 KB, patch)
2014-03-18 12:30 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2014-03-18 09:25:26 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

FlightCrew appears to bundle zipios++ which is available as a separate package in Fedora. Looks like fixing this might take a bit of work but the situation doesn't seem as bad as src/zipios/changes_made.txt in the FlightCrew source tree suggests.
Comment 1 Dan Horák 2014-03-18 10:30:39 EDT
We discussed it with Hans quite long time ago, so I don't remember the details, but IIRC the conclusion was to provide the forked zipios library from the flightgear package. What makes you think the situation is not that bad?
Comment 2 Ville Skyttä 2014-03-18 10:38:16 EDT
Created attachment 875958 [details]
Diff between separate and FlightCrew zipios++

Because the diff between the FlightCrew version and the separately packaged one doesn't look that bad, certainly not "modified beyond recognition". See attachment.
Comment 3 Dan Horák 2014-03-18 11:55:02 EDT
you missed, that FlightCrew adds zipextraction.{cpp,h}, in your diff, but otherwise it really sounds not so different ...
Comment 4 Ville Skyttä 2014-03-18 12:17:53 EDT
(In reply to Dan Horák from comment #3)
> you missed, that FlightCrew adds zipextraction.{cpp,h}, in your diff,

I actually didn't, the .cpp is elsewhere in the source tree so it naturally didn't get included in the diff, and the .h is there:

$ curl -s "https://bugzilla.redhat.com/attachment.cgi?id=875958" | grep zipe
Only in zipios++-flightcrew: zipextraction.h

Anyway they're complete additions, so I don't think they should count as differences per se and can continue to be included.
Comment 5 Dan Horák 2014-03-18 12:30:24 EDT
Created attachment 876026 [details]
use system zipios - preliminary fix

3 subtle changes are required (see top of the diff), the rest is just removal

hmm, how could we miss it ... :-) thanks Ville
Comment 6 Ville Skyttä 2014-03-18 13:13:08 EDT
(In reply to Dan Horák from comment #5)
> 3 subtle changes are required (see top of the diff), the rest is just removal

Would be more concise to do the removals with rm in the spec instead of in a giant patch... and I'll shut up now :)
Comment 7 Dan Horák 2014-03-18 13:21:03 EDT
(In reply to Ville Skyttä from comment #6)
> (In reply to Dan Horák from comment #5)
> > 3 subtle changes are required (see top of the diff), the rest is just removal
> 
> Would be more concise to do the removals with rm in the spec instead of in a
> giant patch... and I'll shut up now :)

yes, that's the plan :-) I just wanted to record the work in progress so it's not lost. Now I'm thinking how to integrate it properly into upstream code to allow builds with/without system zipios.

Note You need to log in before you can comment on or make changes to this bug.