Bug 1077718 - wxGTK3-devel doesn't supply a wx-config symlink
Summary: wxGTK3-devel doesn't supply a wx-config symlink
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1128365
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-18 13:32 UTC by David Hart
Modified: 2016-09-29 22:51 UTC (History)
8 users (show)

Fixed In Version: wxGTK3-3.0.0-7.el6 wxGTK3-3.0.2-23.fc25 wxGTK3-3.0.2-23.fc24 wxGTK3-3.0.2-23.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 00:37:04 UTC


Attachments (Terms of Use)

Description David Hart 2014-03-18 13:32:26 UTC
Description of problem:
The wxGTK3-devel part of the new wxGTK3 package contains a file called /usr/bin/wx-config-3.0 instead of wx-config. This is presumably to avoid clashes with the old wxGTK package.

However installing the wxGTK3 rpms on a fresh FC20 fails to create a symlink called wx-config, even though it deletes any pre-existing wx-config. As a result, the -devel package cannot be used to build wxWidgets applications: a working wx-config script is part of the standard way of doing so.


Additional info:
I've set the version to fc20 as that's what I've tested; however the bug presumably affects the other versions too.

Comment 1 Jeremy Newton 2014-03-18 13:41:50 UTC
It was decided that patching the source code for each wxGTK3 using package would be better than a symlink, as even that would cause a conflict. I will get Dan Horák (the wxgtk maintainer) involved so we can work to resolve this.

Please let me know if patching is not an option for you; I've cc-ed Dan, hopefully this can be resolved easily.

Comment 2 David Hart 2014-03-18 16:00:29 UTC
I'm sure that'll be fine for building fedora packages.

However wxWidgets is also used to build programs outside fedora. Such builds expect to be able to use e.g. $(wx-config --cxxflags) to get the wx compilation flags. It should also be possible to use wx-config --list to see available versions, and e.g --version=2.8 to select a particular build. This was previously possible in fedora.

Of course there are workarounds. The wx-savvy user can specify wx-config-3.0, or he can create his own symlink. However many users won't know that; and anyway, needing to do so is a regression.

Would using update-alternatives be a way forward?

Comment 3 David Roheim 2014-03-29 20:05:24 UTC
Hi,

I have a package that requires wxGTK3. I am waiting to submit the package because of this issue.

I have tried both creating a symlink and paching the source (codelite) of the package.

Symlink works perfect, but when I patch the source I am getting an error. The problem is in /usr/share/cmake/Modules/FindwxWidgets.cmake line 705

find_program(wxWidgets_CONFIG_EXECUTABLE wx-config

rpm -qf /usr/share/cmake/Modules/FindwxWidgets.cmake gives me:

cmake-2.8.12.2-2.fc20.x86_64

So now cmake is looking for wx-config and not wx-config-3.0

I have tested this by changing it to wx-config-3.0 and paching the source. With these changes it compiles and create the package.

Using update-alternatives would be a way I think, as David Hart suggested.

Thoughts?

Comment 4 Jeremy Newton 2014-03-29 20:22:25 UTC
I personally dont care, but if we're going to have alternatives, I need concensus and cooperation the wxGTK. A quicker solution if no one protests,  would be to add the symlink and make the devel file conflict with the other

Comment 5 David Roheim 2014-03-29 20:52:06 UTC
Yes I agree that the symlink is faster (and will solve my problem). But alternatives is the long-term solution I think. If you add the symlink I will not complain :)

Comment 6 Jeremy Newton 2014-03-29 22:42:40 UTC
Well I originally had a symlink anf conflict but it was frowned upon during review. Can you see any reason why I conflict would be negative? Or at least until I can work something out with the wxGTK maintainer? He seems hard to get a hold of...

Comment 7 David Hart 2014-03-30 10:14:22 UTC
I'm not sure I understand the problem.

In my testbed fc20 I have both the 2.8 and 3.0 packages installed, without any visible clash. I've created my own wx-config symlink (to wx-config-3.0). Doing the standard 'wx-config --list' lists the default as 3.0, plus 2.8 in the 'also available in /usr' category.
'wx-config --cxxflags' emits the 3.0 compile flags.
'wx-config --version=2.8 --cxxflags' emits the 2.8 ones.

As I see it, there are 6 possible situations:
1) Fedora packages fixed to call wx-config-3.0.
2) Any fedora packages not yet fixed or, like David Roheim's one, not fixable without considerable kludging, but which are happy with either wx2.8 or wx3.
3) Any fedora packages that can't be fixed to use wx3.
4) Uses of wxGTK-devel outside the official fedora packaging, where the program being built will build against, and run with, either wx2.8 or wx3.
5) Uses of wxGTK-devel outside the official fedora packaging where the program being built requires a specific wx version (atm usually 2.8).
6) wxGTK3-devel is installed alongside wxGTK-devel, and later uninstalled.

Situation 1 'just works', with or without a symlink.
Situation 2 is a special case of #4.
Situation 3 is a special case of #5.
Situation 4: Building currently fails due to the absence of wx-config. Adding the symlink results in success.
Situation 5: Building currently fails due to the absence of wx-config. Adding the symlink results in build failure. However this time the user can see what is going wrong, and has a chance to do something about it. It requires more knowledge of wx-config usage than average, but 'wx-config --help' should point him in the right direction.
Situation 6: Building currently fails due to the absence of wx-config. Just creating a symlink won't fix this, as it'll presumably be deleted again on removal; and even if it's not, it'll be broken as wx-config-3.0 won't be there. This could solved, if you think it's worth the bother, by checking in postun for the existence of /usr/lib(64)/wx/config/gtk-unicode-release-2.8 and creating a new wx-config link to it.

So afaik there's no downside to adding the symlink, and considerable upside.

What am I missing?

Comment 8 Jeremy Newton 2014-03-30 15:47:33 UTC
Y(In reply to David Hart from comment #7
>...
> So afaik there's no downside to adding the symlink, and considerable upside.
> 
> What am I missing?

Well is there a downside to adding a package conflict for just the devel packages to avoid issue in situation 6?

Comment 9 David Hart 2014-03-30 17:08:10 UTC
No major downside that I can think of. A minor one is that anyone wishing to build programs, some of which require wxGTK-devel and others wxGTK3-devel, will have to keep swapping packages; which becomes annoying (the equivalent has happened to me in the past). However it's certainly preferable to the current situation.

Recreating a 2.8 symlink would be a more elegant solution, though.

Comment 10 Jeremy Newton 2014-03-30 20:01:49 UTC
(In reply to David Hart from comment #9)
> No major downside that I can think of. A minor one is that anyone wishing to
> build programs, some of which require wxGTK-devel and others wxGTK3-devel,
> will have to keep swapping packages; which becomes annoying (the equivalent
> has happened to me in the past). However it's certainly preferable to the
> current situation.
> 
> Recreating a 2.8 symlink would be a more elegant solution, though.

Fair enough,  ill have to talk with the wxGTK maintainer

Comment 11 David Roheim 2014-03-30 21:12:57 UTC
One thing that we need to remember (that I wrote about above) is that cmake also expects wx-config to be in /usr/bin. So it is not only wxGTK-devel and wxGTK3-devel, but also cmake. So even if someone would rename all the refs to wx-config-3.0, but uses cmake, they are still stuck. It will get real messy very fast. Like my example. So I hope there can be some sort of agreement between wxGTK and wxGTK3 so that koji will be happy.

Comment 12 Jeremy Newton 2014-03-31 00:17:21 UTC
Understood, my plan of action is to add a symlink to wxGTK3-devel and add a package conflict with wxGTK-devel.  I will contact the wxGTK maintainer about arranging alternatives for the long run

Comment 13 Jeremy Newton 2014-04-04 11:59:08 UTC
This should be fixed in rawhide, expect updates soon for all other branches

Comment 14 Fedora Update System 2014-04-04 12:01:35 UTC
wxGTK3-3.0.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-7.fc19

Comment 15 Fedora Update System 2014-04-04 12:02:45 UTC
wxGTK3-3.0.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-7.fc20

Comment 16 Fedora Update System 2014-04-04 12:03:35 UTC
wxGTK3-3.0.0-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-7.el6

Comment 17 Fedora Update System 2014-04-15 15:41:29 UTC
wxGTK3-3.0.0-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2014-04-15 15:56:49 UTC
wxGTK3-3.0.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2014-04-19 09:19:02 UTC
wxGTK3-3.0.0-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 sheepdestroyer 2014-08-09 11:29:24 UTC
I think I still hit this bug,
I want to build dolphin emulator which uses wxwidgets3
I have wxGTK3-devel installed but cmake search and does not find wxrc nor wx-config

Comment 21 David Hart 2014-12-09 17:01:56 UTC
The fix hasn't been applied to the wxGTK3-devel package in fedora 21. Is this an oversight, or has the plan changed?

Comment 22 Jeremy Newton 2014-12-09 18:56:45 UTC
No this isn't an oversight, it should have been pushed to updates Nov 16th.

https://admin.fedoraproject.org/updates/FEDORA-2014-14855/wxGTK3-3.0.2-2.fc21

Unfortunately it won't let me view the page at the moment, but I have the following records in my email:

Comments: bodhi - 2014-11-12 19:53:09 (karma 0)

             This update has been submitted for testing by
             mystro256.

             mystro256 - 2014-11-12 19:54:59 (karma 0)
             Symlinks have been placed to remain compatible with
             the old layout of scripts in the devel package. Anyone
             testing this, plus test to make sure building works.
             Note that specifying the location of wxrc/wx-config
             might be required. They are located in
             /usr/libexec/wxGTK3

             taskotron - 2014-11-12 20:24:34 (karma 0)
             Taskotron: depcheck test PASSED on i386. Result log: h
             ttps://taskotron.fedoraproject.org/taskmaster//builder
             s/x86_64/builds/12003/steps/runtask/logs/stdio
             (results are informative only)

             taskotron - 2014-11-12 20:26:19 (karma 0)
             Taskotron: depcheck test PASSED on x86_64. Result log:
             https://taskotron.fedoraproject.org/taskmaster//builde
             rs/x86_64/builds/12003/steps/runtask/logs/stdio
             (results are informative only)

             bodhi - 2014-11-13 03:54:38 (karma 0)
             This update is currently being pushed to the Fedora 21
             testing updates repository.

             bodhi - 2014-11-13 18:10:45 (karma 0)
             This update has been pushed to testing

             chr77 - 2014-11-13 21:07:14 (karma 1)
             Works for me

             kuosmanen - 2014-11-14 10:38:52 (karma 1)
             works

             cairo - 2014-11-15 01:19:56 (karma 1)
             bodhi - 2014-11-15 01:20:00 (karma 0)
             This update has reached the stable karma threshold and
             will be pushed to the stable updates repository

             taskotron - 2014-11-15 01:28:09 (karma 0)
             Taskotron: upgradepath test PASSED on noarch. Result
             log: https://taskotron.fedoraproject.org/taskmaster//b
             uilders/x86_64/builds/12960/steps/runtask/logs/stdio
             (results are informative only)

             bodhi - 2014-11-16 02:09:06 (karma 0)
             This update is currently being pushed to the Fedora 21
             stable updates repository.

             bodhi - 2014-11-16 14:40:08 (karma 0)
             This update has been pushed to stable

Are you sure that wxGTK3-devel-3.0.2-2 is not available in f21?

Comment 23 Jeremy Newton 2014-12-09 18:58:27 UTC
I'm assuming the high traffic due to the release has messed everything up:

http://status.fedoraproject.org/

Comment 24 Jeremy Newton 2014-12-09 19:08:41 UTC
Honestly, I have no idea what the issue is, unless it's just a mirror lagging. It seems to be available:

https://apps.fedoraproject.org/packages/wxGTK3-devel

Comment 25 David Hart 2014-12-09 20:23:19 UTC
>Are you sure that wxGTK3-devel-3.0.2-2 is not available in f21?

It is available, and I installed it in both a 32 bit 'workstation' and a 64 bit kde-spin f21. In neither was a /usr/bin/wx-config symlink installed. And btw, there doesn't seem to be a conflict with the 2.8 wxGTK-devel.

However,looking inside a wxGTK3-devel package, I see that there _is_ a /usr/libexec/wxGTK3/wx-config, and /usr/lib/wx-config-3.0 points to it; which makes me wonder if I misunderstood what the fix was supposed to implement.

To avoid any confusion on my part, is there now supposed to be a wx-config symlink in /usr/bin/? If not, as explained upthread, the wxGTK3-devel package is of limited use.

Comment 26 Jeremy Newton 2014-12-09 21:11:21 UTC
Oh I see the confusion.

No I can't make a conflict with wxGTK-devel at the request of one of my sponsors. I put it in libexec as a compromise unfortunately.

Is this an issue for you? Most applications should have a configure option to select the location of the wxconfig file.

If /usr/libexec/wxGTK3/wx-config does not work for you, I would suggest marking this bug as duplicate of or blocked by the following bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1128365

The bug is against wxGTK. I wish to set up alternatives but at the moment the dev does not seem interested. Unfortunately I can't fix that bug without the wxGTK dev's co-operation.

Comment 27 David Hart 2014-12-09 22:56:20 UTC
I see. Thank you for the information, and for the link to 1128365 and (indirectly) to 1124402.

>Most applications should have a configure option to select the location of the wxconfig file.

Indeed, workarounds are possible (including creating a DIY symlink). But the average wxgtk user will expect the official wx package to provide a wx-config symlink in /usr/bin/ (or, second-best, elsewhere in $PATH), as happened in all fedoras <20, and as happens in all other distros I've ever looked at. So it does indeed remain an issue, and one that IMO should be fixed.

I've put 1128365 in the 'Depends On' field, which presumably equates to 'blocked by'.

Comment 28 Jeremy Newton 2014-12-09 23:57:58 UTC
No problem, that seems fair.

As I said, I need the co-operation of the wxGTK maintainer, so feel free to email him (Dan Horák), and cc me, if you feel like this needs more attention.

Comment 29 Edip Ahmet 2015-01-04 22:27:20 UTC
When I try to install SAGA GIS software from source on fedora20, the software requires WxGTK3 as default. but when I run "make" it uses WxGTK2 instead of WxGTK3.

Installation of software instructions are respectively: "autoreconf -i", "./configure", "make" and "make install". However errors accured after "make". It is due to the fact that tryes to install default GUI as WxGTK2 instead of WxGTK3. 
Solution: Prepending /usr/libexec/wxGTK3/ to your PATH as: PATH=/usr/libexec/wxGTK3/:$PATH
After prepending this, It can configure WxGTK3 as default and the software can be installed.

Comment 30 Dan Horák 2015-01-05 08:38:48 UTC
(In reply to Jeremy Newton from comment #28)
> No problem, that seems fair.
> 
> As I said, I need the co-operation of the wxGTK maintainer, so feel free to
> email him (Dan Horák), and cc me, if you feel like this needs more attention.

Jeremy, if you have the required change for wxGTK prepared, please attach it here. I can also give you comaintainer status for wxGTK, as you can see I don't much time left for wxGTK.

Comment 31 Jeremy Newton 2015-01-05 10:17:42 UTC
(In reply to Dan Horák from comment #30)
> (In reply to Jeremy Newton from comment #28)
> > No problem, that seems fair.
> > 
> > As I said, I need the co-operation of the wxGTK maintainer, so feel free to
> > email him (Dan Horák), and cc me, if you feel like this needs more attention.
> 
> Jeremy, if you have the required change for wxGTK prepared, please attach it
> here. I can also give you comaintainer status for wxGTK, as you can see I
> don't much time left for wxGTK.

I can make a patch for you tomorrow, but if you can give me co-maintainership, that would be much easier for the both of us. I'm happy maintaining both if you don't have time for wxGTK.

Comment 32 Fedora End Of Life 2015-05-29 11:17:55 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 33 Fedora End Of Life 2015-06-29 19:33:52 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 34 Ben Rosser 2016-02-29 06:44:01 UTC
Appears to still be valid in F22/F23.

Comment 35 Jeremy Newton 2016-03-01 12:53:53 UTC
Please refer to bug 1128365, this can't be fixed unless that is fixed first.

Marking as can't fix for now. Please reopen that bug first if you wish to fix this.

Comment 36 Jeremy Newton 2016-05-06 15:19:27 UTC
Re-opening, as I should be able to fix bug 1128365 now

Comment 37 Fedora Update System 2016-09-15 15:00:53 UTC
wxGTK-2.8.12-24.fc23 wxGTK3-3.0.2-21.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-835be81af6

Comment 38 Fedora Update System 2016-09-15 15:01:16 UTC
wxGTK-2.8.12-24.fc24 wxGTK3-3.0.2-21.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2d04da1545

Comment 39 Fedora Update System 2016-09-15 15:01:33 UTC
wxGTK-2.8.12-24.fc25 wxGTK3-3.0.2-21.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e3e076fdba

Comment 40 Fedora Update System 2016-09-16 00:51:53 UTC
wxGTK-2.8.12-24.fc23, wxGTK3-3.0.2-21.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-835be81af6

Comment 41 Fedora Update System 2016-09-16 00:53:26 UTC
wxGTK-2.8.12-24.fc24, wxGTK3-3.0.2-21.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2d04da1545

Comment 42 Fedora Update System 2016-09-16 01:23:59 UTC
wxGTK-2.8.12-24.fc25, wxGTK3-3.0.2-21.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e3e076fdba

Comment 43 Arnaud 2016-09-16 17:26:02 UTC
I got these messages in dnf when updating:

------
Update : wxGTK-devel-2.8.12-24.fc23.x86_64   
failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config: /usr/bin/wx-config exists and it is not a symlink

Update : wxGTK3-devel-3.0.2-21.fc23.x86_64
failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config: /usr/bin/wx-config exists and it is not a symlink
------

# ll /usr/bin/wx-config
-rwxr-xr-x. 1 root root 890 19 jun  2015 /usr/bin/wx-config
# ll /etc/alternatives/wx-config
lrwxrwxrwx. 1 root root 29 16 sep 19:20 /etc/alternatives/wx-config -> /usr/libexec/wxGTK3/wx-config

Comment 44 Jeremy Newton 2016-09-19 02:12:25 UTC
can you try updating wxGTK-* first then wxGTK3-*?

Comment 45 Jeremy Newton 2016-09-19 02:35:38 UTC
(In reply to Heldwin from comment #43)
> I got these messages in dnf when updating:
> 
> ------
> Update : wxGTK-devel-2.8.12-24.fc23.x86_64   
> failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config:
> /usr/bin/wx-config exists and it is not a symlink
> 
> Update : wxGTK3-devel-3.0.2-21.fc23.x86_64
> failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config:
> /usr/bin/wx-config exists and it is not a symlink
> ------
> 
> # ll /usr/bin/wx-config
> -rwxr-xr-x. 1 root root 890 19 jun  2015 /usr/bin/wx-config
> # ll /etc/alternatives/wx-config
> lrwxrwxrwx. 1 root root 29 16 sep 19:20 /etc/alternatives/wx-config ->
> /usr/libexec/wxGTK3/wx-config

I can't reproduce this. This is either because wxGTK3-devel is being updated prior to wxGTK-devel, or because the update isn't removing /usr/bin/wx-config properly. A workaround would be to delete the file prior to updating, like so:

sudo rm /usr/bin/wx-config
sudo update wxGTK-devel wxGTK3-devel --enablerepo=updates-testing --allowerasing --best

Comment 46 Arnaud 2016-09-19 19:06:06 UTC
I downgraded wxBase* and wxGTK*, then I tried to update only wxBase and wxGTK-*, but I get again this message:

wxGTK-devel-2.8.12-24.fc23.x86_64
failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config: /usr/bin/wx-config exists and it is not a symlink

also if I do after that an upgrade for wxBase3 and wxGTK3*

If I delete /usr/bin/wx-config manually, and then update the packages, all is fine.

Comment 47 Fedora Update System 2016-09-20 03:50:10 UTC
wxGTK3-3.0.2-23.fc23 wxGTK-2.8.12-26.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6af21a57ce

Comment 48 Fedora Update System 2016-09-20 03:50:34 UTC
wxGTK3-3.0.2-23.fc24 wxGTK-2.8.12-26.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3560aaba49

Comment 49 Fedora Update System 2016-09-20 03:50:53 UTC
wxGTK3-3.0.2-23.fc25 wxGTK-2.8.12-26.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-89935dbd98

Comment 50 Fedora Update System 2016-09-20 19:57:10 UTC
wxGTK-2.8.12-26.fc25, wxGTK3-3.0.2-23.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-89935dbd98

Comment 51 Jeremy Newton 2016-09-20 23:24:52 UTC
(In reply to Heldwin from comment #46)
> I downgraded wxBase* and wxGTK*, then I tried to update only wxBase and
> wxGTK-*, but I get again this message:
> 
> wxGTK-devel-2.8.12-24.fc23.x86_64
> failed to link /usr/bin/wx-config -> /etc/alternatives/wx-config:
> /usr/bin/wx-config exists and it is not a symlink
> 
> also if I do after that an upgrade for wxBase3 and wxGTK3*
> 
> If I delete /usr/bin/wx-config manually, and then update the packages, all
> is fine.

This workaround has been incorporated into the update. Thanks for the report.

Comment 52 Fedora Update System 2016-09-22 01:24:57 UTC
wxGTK-2.8.12-26.fc23, wxGTK3-3.0.2-23.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6af21a57ce

Comment 53 Fedora Update System 2016-09-22 01:25:51 UTC
wxGTK-2.8.12-26.fc24, wxGTK3-3.0.2-23.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3560aaba49

Comment 54 Fedora Update System 2016-09-27 00:37:04 UTC
wxGTK-2.8.12-26.fc25, wxGTK3-3.0.2-23.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 55 Fedora Update System 2016-09-27 03:51:40 UTC
wxGTK-2.8.12-26.fc24, wxGTK3-3.0.2-23.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 56 Fedora Update System 2016-09-29 22:51:17 UTC
wxGTK-2.8.12-26.fc23, wxGTK3-3.0.2-23.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.