Bug 107777 - Sony CPD-200GS modelines incorrect - visual distortion at top of display
Sony CPD-200GS modelines incorrect - visual distortion at top of display
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 17:03 EDT by Scott R. Godin
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 12:07:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott R. Godin 2003-10-22 17:03:27 EDT
Description of problem:
Despite my every effort, including both re-confirming what is in the manual for
the monitor (yes, I have the manual) and comparing it to what is in the settings
of redhat-config-xfree86, and additionally attempting to further tweak these
settings manually via the advanced tab, I have been unsuccessful at removing the
visual distortion at the top of the screen.

Basically, it's livable at 1280x1024, but at smaller resolutions it gets worse.
Much worse. at 800x600 or 640x480 it is as though there is a sine-wave curve at
the top of the display (along the sides you can see the curve) and the
distortion occurs lengthwise across the screen, moving the pixels right or left
in a gradually decreasing curve from the top to approximately 1/4 of the way
down the screen. So, the lower 3/4 of the screen look acceptably OK, but the top
has visual distortions to great to ignore at smaller resolutions. 

This is particularly disturbing when you run some game that reduces the
screenres to 800x600 or less, as you cannot read the text that appears across
the top of the screen at that point. 

Yes I am currently using the nvidia driver installed by
NVIDIA-Linux-x86-1.0-4496-pkg2.run, however the distortion remains even when
using the default 'nv' driver. Also running different window managers has not
affected this one whit (not that I thought it would, but I thought it prudent to
check, anyway). 

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
always

Steps to Reproduce:
1.connect a Sony CPD-200GS to the system, install Red Hat 9
2. run redhat-config-xfree86 and confirm that the proper settings are selected.
set the screen resolution to *anything* less than 1280x1024 (even though at that
point it is still visible, smaller res's increase the amount of visual distortion)
3. startx or boot to the GUI
    
Actual results:
as describe above

Expected results:
no distortion

Additional info:
I even tried running the modeline generators I was able to discover by googling
around a bit, and while the modelines they generated were different from what's
currently in my XF86Config file, the distortions were not resolved to any degree
whatsoever. Moving this monitor to my PowerMac 7600/132 to confirm that the
Display itself is not at fault produced a perfectly sharp display with no
waviness at the top. 

ANY assistance with this would be MOST appreciated. I will be happy to try any
suggested tests or supply ANY additional info that may help to resolve this. My
eyes just can't take it anymore and I've run out of things to try on my own and
while I should have bugzilla'd this earlier I had _hoped_ to come up with a
resolution on my own that I could simply post. bleh. :-) 

If a visual aid is required, let me know, and I'll try and borrow a digicam to
grab a snapshot of the monitor with.
Comment 1 Scott R. Godin 2003-10-22 17:05:10 EDT
ugh, I wish I had proofread the above, and further wish I could edit my original
post to remove the typos. That should read "too great to ignore" Not "to great
to ignore". Yes I'm picky and detail oriented. sue me. :)
Comment 2 Mike A. Harris 2003-11-10 12:07:52 EST
Video modelines that are built into the X server are industry
standard VESA GTF modelines defined by the VESA GTF (General
Timing Formula) specification.  These modes are standardized,
and are not specific to any hardware.  Your display may not
be VESA GTF compliant, and so it is possible your display
may display shifted modes.

Moving your monitor to your PowerMAC is not a conclusive test
because your monitor would either be autodetected by Mac OS
(or Microsoft Windows for that matter), and the Mac or Windows
supplied .INF database files (or whatever Mac uses) would
provide any special override modes or configuration in addition
to the standard VESA GTF modes built into the operating system.

Linux/XFree86 supplies only VESA GTF modelines and other
standard modelines which predate the VESA GTF specification.

If your display is not VESA GTF compliant then it may require
customized modelines, which you will have to enter by hand
into the config file.  You may want to look at the manufacturer's
.INF files for this monitor (or the equivalent Mac metadata files)
as they may supply customized modelines for the display.

I don't consider this problem to be an XFree86 bug however,
but rather a technical support problem.  Please use the XFree86
mailing lists such as xfree86@xfree86.org for tips on tweaking
modelines.  You may also want to search google for your monitor's
model plus the keyword XFree86, in case others with this model
of monitor have had similar problems.


Note You need to log in before you can comment on or make changes to this bug.