Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
From virt-manager, when force off vm during saving, Saving Virtual
Machine Process window will hang and could not quit.
Version-Release number of selected component:
virt-manager-0.10.0-18.el7.noarch
How reproducible:
100%
Steps to Reproduce:
1. Start virt-manager with --debug and prepare a running guest with GUI and big disk image which would take a long time to save.
2. "Save" this guest by selecting "Shut Down" -> "Save" and Click
"Yes" button for confirm window, Quickly force off this guest during
saving process.
3. Error shutting down domain window will pop up, and click "Close" button
Actual result:
1. Saving Virtual Machine Process window will hang, and could not quit even
if quit virt-manager.
2. Here is --debug output:
-----------------------------------------------
2014-03-19 16:21:52,388 (engine:869): Destroying vm 'rhel6u5-clone4'
2014-03-19 16:21:52,389 (asyncjob:190): Creating async job for
function cb=<function tmpcb at 0x2501578>
2014-03-19 16:21:52,491 (error:81): error dialog message:
summary=Error shutting down domain: Requested operation is not valid:
domain is not running
details=Error shutting down domain: Requested operation is not valid:
domain is not running
Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in
cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in
tmpcb
callback(*args, **kwargs)
File "/usr/share/virt-manager/virtManager/domain.py", line 1201, in
destroy
self._backend.destroy()
File "/usr/lib64/python2.7/site-packages/libvirt.py", line 750, in
destroy
if ret == -1: raise libvirtError ('virDomainDestroy() failed',
dom=self)
libvirtError: Requested operation is not valid: domain is not running
-----------------------------------------------
Expected results:
1. Saving Virtual Machine Process window should be quit, OR, Could not force
off vm during saving process.
Additional info:
1. This issue does not occur on RHEL6
This bug was fixed by rebase in RHEL-7.1 to virt-manager-1.1.0. Now the Saving Virtual Machine Process window is closed and an error message window is displayed.
I can reproduce this bug on the following version:
virt-manager-0.10.0-18.el7.noarch
virt-install-0.10.0-18.el7.noarch
Steps are the same as Comment 0 shows.
Then verify with the latest package:
virt-manager-1.2.1-2.el7.noarch
virt-install-1.2.1-2.el7.noarch
Steps:
1. Start virt-manager and prepare a running guest with GUI and big disk image which would take a long time to save.
2. "Save" this guest by selecting "Shut Down" -> "Save", Quickly force off this guest during saving process.
3. Error shutting down domain window will pop up, and click "Close" button.
Results:
During Step 3, the 'Saving Virtual Machine Process' window is closed and an error message window is displayed. After the 'Close' button was clicked, no hang-up window appears.
According to the result shown above, move this bug from ON_QA to VERIFIED.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHBA-2015-2206.html
Description of problem: From virt-manager, when force off vm during saving, Saving Virtual Machine Process window will hang and could not quit. Version-Release number of selected component: virt-manager-0.10.0-18.el7.noarch How reproducible: 100% Steps to Reproduce: 1. Start virt-manager with --debug and prepare a running guest with GUI and big disk image which would take a long time to save. 2. "Save" this guest by selecting "Shut Down" -> "Save" and Click "Yes" button for confirm window, Quickly force off this guest during saving process. 3. Error shutting down domain window will pop up, and click "Close" button Actual result: 1. Saving Virtual Machine Process window will hang, and could not quit even if quit virt-manager. 2. Here is --debug output: ----------------------------------------------- 2014-03-19 16:21:52,388 (engine:869): Destroying vm 'rhel6u5-clone4' 2014-03-19 16:21:52,389 (asyncjob:190): Creating async job for function cb=<function tmpcb at 0x2501578> 2014-03-19 16:21:52,491 (error:81): error dialog message: summary=Error shutting down domain: Requested operation is not valid: domain is not running details=Error shutting down domain: Requested operation is not valid: domain is not running Traceback (most recent call last): File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper callback(asyncjob, *args, **kwargs) File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb callback(*args, **kwargs) File "/usr/share/virt-manager/virtManager/domain.py", line 1201, in destroy self._backend.destroy() File "/usr/lib64/python2.7/site-packages/libvirt.py", line 750, in destroy if ret == -1: raise libvirtError ('virDomainDestroy() failed', dom=self) libvirtError: Requested operation is not valid: domain is not running ----------------------------------------------- Expected results: 1. Saving Virtual Machine Process window should be quit, OR, Could not force off vm during saving process. Additional info: 1. This issue does not occur on RHEL6