Bug 107825 - libgmp requires an executable stack?
libgmp requires an executable stack?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 10:14 EDT by Joe Orton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.1.2-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 11:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2003-10-23 10:14:59 EDT
Ingo's lsexec script shows that exec-shield is disabled in httpd because libgmp
(picked up via PHP) doesn't have the correct object file markings, doubtless in
the assembler...

(httpd) 22401 (bff6d000 ): execshield disabled
 => /usr/lib/libgmp.so.3.3.2 disables exec-shield!

can the markings be added to the assembler, presuming that gmp really doesn't
require an executable stack?
Comment 1 Joe Orton 2003-10-23 10:27:23 EDT
Oh, actually I think I can do this myself...

export CCAS="gcc -c -Wa,--execstack"

wasn't so hard - I'll commit the changes.

Note You need to log in before you can comment on or make changes to this bug.