Bug 1078297 - Failing qa tests: crashrecovery12 CrashRecovery12_Test02 when run with jdbc object store
Summary: Failing qa tests: crashrecovery12 CrashRecovery12_Test02 when run with jdbc o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: EAP 6.4.0
Assignee: Michael
QA Contact: Ondrej Chaloupka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-19 14:48 UTC by Ondrej Chaloupka
Modified: 2019-08-19 12:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
Test output (19.05 KB, text/plain)
2014-03-19 14:48 UTC, Ondrej Chaloupka
no flags Details
client0_output.txt (11.22 KB, text/plain)
2014-03-19 14:48 UTC, Ondrej Chaloupka
no flags Details
emptyObjectStore_output.txt (7.85 KB, text/plain)
2014-03-19 14:49 UTC, Ondrej Chaloupka
no flags Details
outcome0_output.txt (4.48 KB, text/plain)
2014-03-19 14:49 UTC, Ondrej Chaloupka
no flags Details
server0_output.txt (6.98 KB, text/plain)
2014-03-19 14:50 UTC, Ondrej Chaloupka
no flags Details
setup0_output.txt (3.04 KB, text/plain)
2014-03-19 14:50 UTC, Ondrej Chaloupka
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTM-2130 Major Closed All JDBC object store qa tests fail 2014-08-26 12:36:42 UTC
JBoss Issue Tracker JBTM-2133 Minor Closed Multiple QA test suite failures on Oracle 2014-08-26 12:36:42 UTC

Description Ondrej Chaloupka 2014-03-19 14:48:10 UTC
Created attachment 876372 [details]
Test output

There are failures for qa tests when running with jdbc object store (failing consistently on all tested dbs):
crashrecovery12 CrashRecovery12_Test02
crashrecovery12 CrashRecovery12_Test03
crashrecovery12 CrashRecovery12_Test04
crashrecovery12 CrashRecovery12_Test05
crashrecovery12 CrashRecovery12_Test06
crashrecovery12 CrashRecovery12_Test07

Running on Narayana 4.17.17.Final.

Comment 1 Ondrej Chaloupka 2014-03-19 14:48:51 UTC
Created attachment 876376 [details]
client0_output.txt

Comment 2 Ondrej Chaloupka 2014-03-19 14:49:18 UTC
Created attachment 876377 [details]
emptyObjectStore_output.txt

Comment 3 Ondrej Chaloupka 2014-03-19 14:49:45 UTC
Created attachment 876379 [details]
outcome0_output.txt

Comment 4 Ondrej Chaloupka 2014-03-19 14:50:03 UTC
Created attachment 876380 [details]
server0_output.txt

Comment 5 Ondrej Chaloupka 2014-03-19 14:50:22 UTC
Created attachment 876382 [details]
setup0_output.txt

Comment 7 Michael 2014-03-20 17:38:57 UTC
The failure is because the test is timing out waiting for the recovery system to recover failed transactions. I have seen this before on very slow connections to the db hosting the transaction logs. 

Is this something that is reproducible. If not then I would be tempted to close as cannot reproduce. Note that this is safe because the logs are still in the db and the recovery system would eventually replay the pending transactions.

Comment 8 Ondrej Chaloupka 2014-03-21 07:52:29 UTC
Hi Mike,

ok, I see. So is there some way how to increase the timeout or something?
The a bit strange thing is that this was not happening in previous testing cycle what I can say. But there could be some changes in our networking infrastructure.

What I can say it's easily reproducible if you try to run the test in the way that's described in comment #6. There are connection to our testing oracle database. But this happening for any database in our lab. I've tested against my local postgres installation:
ant -f run-tests.xml -Dtest.name=crashrecovery12 -Dtest.methods="CrashRecovery12_Test02" -Dprofile=postgres -Djdbc.db.url="localhost" -Djdbc.db.name=crashrec -Djdbc.db.user=crashrec -Djdbc.db.password=crashrec -Djdbc.db.port=5432 onetest

And fails are consistent there too.

Comment 11 JBoss JIRA Server 2014-04-09 15:03:30 UTC
Tom Jenkinson <tom.jenkinson@redhat.com> updated the status of jira JBTM-2133 to Closed

Comment 12 JBoss JIRA Server 2014-04-09 15:03:33 UTC
Tom Jenkinson <tom.jenkinson@redhat.com> updated the status of jira JBTM-2130 to Closed

Comment 13 Ondrej Chaloupka 2014-05-28 13:50:09 UTC
I've tested this with EAP 6.3.0.ER5 with version 4.17.20.Final. The failures mentioned here are still valid.

Comment 14 Ondrej Chaloupka 2014-07-08 13:54:26 UTC
The same for EAP 6.3.0.ER9 on 4.17.21.Final.

Comment 15 Ondrej Chaloupka 2014-08-22 06:42:05 UTC
We discussed this with Mike and I found out that issue was already solved by JBTM-2130. 
The remaining fails were only test issue.

There were two things - as the test with jdbc object store was not working I set too big number of MFACTOR (about 40) and it causes that this test were failing. When I put it to something normal like 3 test started to pass.
Then the reproducer on my local machine was not working as I did set MFACTOR but I run it manually and I didn't consider that the system variable MFACTOR is recognized just when using narayana.sh script. When running by hand the TaskImpl.properties are needed to be change directly (e.g. COMMAND_LINE_12=-DCoreEnvironmentBean.timeoutFactor=2, COMMAND_LINE_13=-DCoordinatorEnvironmentBean.defaultTimeout=240)

Setting as verified on Naryana 4.17.21.Final (what is version of EAP 6.3.0.GA)

Thanks and sorry Mike
o.

Jenkins job tested here:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-jbossts-qa-test-jdbc-store-bz1078297


Note You need to log in before you can comment on or make changes to this bug.