Bug 1078319 - core(5) man page shows wrong default value for coredump_filter
Summary: core(5) man page shows wrong default value for coredump_filter
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks: 1104125
TreeView+ depends on / blocked
 
Reported: 2014-03-19 15:25 UTC by Marc Milgram
Modified: 2018-12-09 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: man page showed wrong default values for coredump_filter and incomplete descriptions of all bits. Consequence: incomplete and incorrect documentation Fix: description of missing bits added and default value corrected Result: correct documentation for coredump_filter
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 07:27:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description Marc Milgram 2014-03-19 15:25:13 UTC
Description of problem:
core(5) man page shows incorrect default value for coredump_filter.  It should show 0x33

Also, just above this point it lists meanings for bits 0-3, but there are meanings for bits 4-6.

Version-Release number of selected component (if applicable):
man-pages-3.22-20.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. man core
2. /coredump_filter

Actual results:
Shows following text:
           bit 0  Dump anonymous private mappings.
           bit 1  Dump anonymous shared mappings.
           bit 2  Dump file-backed private mappings.
           bit 3  Dump file-backed shared mappings.

       The default value of coredump_filter is 0x3; this reflects  traditional
       Linux  behavior  and  means  that  only  anonymous  memory segments are
       dumped.


Expected results:
Lists values for all relevant bits, and specifies the default value of coredump_filter is 0x33.

Additional info:
The remaining bits should be:
           bit 4  Dump ELF headers.
           bit 5  Dump huge pages that have private mappings
           bit 6  Dump huge pages that have shared mappings.

Comment 2 Peter Schiffer 2014-04-22 13:14:05 UTC
This is fixed in upstream, only backport is needed:
http://man7.org/linux/man-pages/man5/core.5.html

Comment 7 errata-xmlrpc 2014-10-14 07:27:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.