Bug 107834 - RFE: Compile kernel with CONFIG_NLS_DEFAULT="utf8"
RFE: Compile kernel with CONFIG_NLS_DEFAULT="utf8"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 11:52 EDT by Mikko Paananen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 13:47:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikko Paananen 2003-10-23 11:52:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031017
Firebird/0.7

Description of problem:
Filesystems that use unicode internally need charset conversion for filenames,
kernel default is still to convert to iso8859-1. Unfortunately this leads to
problems with FC's default unicode (UTF-8) environment.

Latest Fedora Core kernel config still uses default setting:
$ grep CONFIG_NLS_DEFAULT /boot/config-2.4.22-1.2088.nptl
CONFIG_NLS_DEFAULT="iso8859-1"

To correctly show filenames on unicode environment right encoding is "utf8".

Filesystems that use unicode internally include:
vfat, ntfs, jfs, iso9660 with joliet and smbfs.


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2088.nptl

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core
2. Mount VFAT partions during install
3. Or mount any VFAT floppy with non-ascii filenames


Actual Results:  Filenames with non-ascii characters are converted to
iso-8859-1, that is inappropriate with otherwise unicode system. Nautilus will
complain about illegal unicode and 'ls' in terminal window shows '?'s instead of
letters on such filesystems.


Expected Results:  Non-ascii characters should be presented in UTF-8.


Additional info:

Kernel default nls can be overridden with option iocharset=utf8 when mounting
filesystem that is internally unicode aware, however neither anaconda nor kuzdu
use this option.

I think that it is easier to fix this by adjusting kernel default behaviour,
since this config change has minimal impact on anything else and it also get
things right when user manually mounts something without specifying iocharset.
Comment 1 Heikki Keranen 2003-11-29 08:41:13 EST
This seems to be same bug as #110231. I wonder if correcting this will
solve the problem that burning files having scandinavic characters (ö
and ä) in their names with Nautilus Burn do not show right in Windows
(XP). I'am too lazy to try compiling kernel.

Mikko, do you have possibility to try this? If it doesn't help then we
need to make another bugreport I gues.
Comment 2 Mikko Paananen 2003-12-02 12:35:29 EST
I haven't used it, but Nautilus cd burner is probably broken because
mkisofs doesn't support UTF-8 and Joliet correctly, and because of
that every cd burning program under Linux has same problem.

See bugs #87613 and #106479 for more information and workarounds.
Comment 3 Alan Cox 2004-06-21 13:47:31 EDT
FC2 

Note You need to log in before you can comment on or make changes to this bug.