Bug 1078437 - Attempts to add Filters to JBoss ON Http Content Source gives error
Summary: Attempts to add Filters to JBoss ON Http Content Source gives error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Content
Version: JON 3.2
Hardware: All
OS: All
high
high
Target Milestone: DR03
: JON 3.2.2
Assignee: Lukas Krejci
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-19 17:16 UTC by dsteigne
Modified: 2018-12-05 17:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 00:17:17 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1081597 None None None Never
Red Hat Knowledge Base (Solution) 759693 None None None Never

Internal Links: 1081597

Description dsteigne 2014-03-19 17:16:37 UTC
Description of problem:
Attempts to add Filters to JBoss ON Http Content Source gives error in version 3.2.  

When creating a Http or URL Content Source, I can create it by specifying the Name, Description, Root URL, and Index File.  However, when I try to add a Package Type by clicking the "Add New" button, it throws an error. This is preventing me from finding any content.

~~~
Error
The page requested cannot be displayed due to some error.
return to the previous page, Dashboard, or Browse Resources Page.

/portal/rhq/content/contentProvider-add-map-plain.xhtml
~~~

Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Administration > Content > Content Sources
2. Click "Create New" > HTTP Content source
3. Enter a Name and URL, then under Package Types click "Add New"
4. Error box appears

Actual results:


Expected results:


Additional info:

Comment 1 Lukas Krejci 2014-06-16 22:35:06 UTC
master d3fb7a117a2f11cb16256eea9cb6ed7ded222049
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Jun 17 00:26:46 2014 +0200

    [BZ 1078437] Correct the navigation in content subsystem JSF pages
    
    The /portal prefix is only valid in the <redirect/> navigation cases
    because in those cases it is represented literally as the URL to go to.
    
    In all other cases it is a logical name that wasn't affected by the move of
    the JSF UI to the /portal context root.

release/jon3.2.x e9f8a8f584df7bfd28738e70feb9eade98cab50c
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Jun 17 00:26:46 2014 +0200

    [BZ 1078437] Correct the navigation in content subsystem JSF pages
    
    The /portal prefix is only valid in the <redirect/> navigation cases
    because in those cases it is represented literally as the URL to go to.
    
    In all other cases it is a logical name that wasn't affected by the move of
    the JSF UI to the /portal context root.
    
    (cherry picked from commit d3fb7a117a2f11cb16256eea9cb6ed7ded222049)
    Signed-off-by: Lukas Krejci <lkrejci@redhat.com>

Comment 2 Simeon Pinder 2014-06-30 06:03:06 UTC
Moving to ON_QA as available for test in latest build:
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.2.2.GA/6-28-2014/

Comment 3 Sunil Kondkar 2014-07-01 13:24:44 UTC
Verified on JBoss ON 3.2.2 DR03 build. There is no error on adding a package type by clicking the "Add New" button.

Comment 4 Larry O'Leary 2014-07-29 00:17:17 UTC
This has been verified and released in Red Hat JBoss Operations Network 3.2 Update 02 (3.2.2) available from the Red Hat Customer Portal[1].



[1]: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=31783


Note You need to log in before you can comment on or make changes to this bug.