Bug 1078524 - Use system double-conversion instead of bundled one
Use system double-conversion instead of bundled one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt5-qtdeclarative (Show other bugs)
rawhide
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Patch, Reopened
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-03-19 16:05 EDT by Ville Skyttä
Modified: 2016-05-21 15:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-21 11:40:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use system double-conversion instead of bundled one (7.18 KB, patch)
2014-03-19 16:05 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2014-03-19 16:05:13 EDT
Build tested fix attached, want me to push and build this for devel?
Comment 1 Ville Skyttä 2014-03-19 16:05:19 EDT
Created attachment 876605 [details]
Use system double-conversion instead of bundled one
Comment 2 Rex Dieter 2014-03-20 13:48:00 EDT
I like, but I'd prefer to keep the the related patches for the bundled code where system copies are not yet available (ie, EPEL).

I'll adapt this to suit.
Comment 3 Milan Bouchet-Valat 2015-01-01 07:17:31 EST
Sure, it would even be useful for me. I've requested it on bug 1040027.
Comment 4 Johnny Robeson 2015-01-01 19:08:09 EST
added to epel testing now: https://bugzilla.redhat.com/show_bug.cgi?id=1177998
please give karma: https://admin.fedoraproject.org/updates/double-conversion-2.0.1-3.el7
Comment 5 Jaroslav Reznik 2015-03-03 11:59:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 6 Rex Dieter 2016-05-20 09:29:38 EDT
Sorry for the delay, was looking at the attached patch for inclusion now, but it seems to be missing  qtdeclarative-opensource-src-5.2.1-system-doubleconv.patch
Comment 7 Ville Skyttä 2016-05-20 11:56:40 EDT
(In reply to Rex Dieter from comment #6)
> it seems to be missing 
> qtdeclarative-opensource-src-5.2.1-system-doubleconv.patch

It's not missing, Bugzilla's patch viewer just eats patches for breakfast (there's at least bug 554878 reported for this).

Use the link in the Attachments box:
 https://bugzilla.redhat.com/attachment.cgi?id=876605
Comment 8 Rex Dieter 2016-05-20 12:01:07 EDT
Thanks, I see it now.  I'll integrate it soon (today hopefully)
Comment 9 Rex Dieter 2016-05-20 12:55:53 EDT
%changelog
* Fri May 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-9
- Use system double-conversion (#1078524)
Comment 10 Raphael Groner 2016-05-20 16:04:21 EDT
The patch broke ABI for both python-qt5¹ and qupzilla².

¹ http://koji.fedoraproject.org/koji/taskinfo?taskID=14191737
² http://koji.fedoraproject.org/koji/taskinfo?taskID=14192034
Comment 11 Rex Dieter 2016-05-20 16:12:11 EDT
ild/moc_kwalletplugin.cpp
/usr/lib/gcc/x86_64-redhat-linux/6.1.1/../../../../lib64/libQt5WebEngineCore.so: undefined reference to `pci_init@LIBPCI_3.0'

Pretty sure that is unrelated to this change, but I'll look closers later tonight
Comment 12 Rex Dieter 2016-05-21 11:40:59 EDT
I've confirmed that symbol comes from pciutils, for which a new version landed recently in rawhide,

I commented on
https://bugzilla.redhat.com/show_bug.cgi?id=1337735#c5

closing here.


In the meantime, I'll probably submit a new qtwebengine build that may fix this in the short term, but that won't fix the pciutils ABI break either.

Note You need to log in before you can comment on or make changes to this bug.