Bug 1078608 - ValueError exception was throw when configuring "Other Device" into "/dev/sda, /dev/sdb"
Summary: ValueError exception was throw when configuring "Other Device" into "/dev/sda...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1097403 rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-03-20 02:34 UTC by haiyang,dong
Modified: 2016-02-10 20:02 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, in the Hypervisor 6.5 installation TUI, providing a path for in the 'Other Device' field to boot the Hypervisor when a different device path had previously been selected caused a ValueError exception to be thrown. Now, the custom device parser has been fixed and providing a second device path in the 'Other Device' field works as expected.
Clone Of:
: 1097403 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:54:28 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached Screenshot for valueerror (4.49 KB, image/png)
2014-03-20 02:34 UTC, haiyang,dong
no flags Details
attached Screenshot for debug console (27.61 KB, image/png)
2014-03-20 02:35 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 25920 None None None Never

Description haiyang,dong 2014-03-20 02:34:28 UTC
Created attachment 876696 [details]
attached Screenshot for valueerror

Description of problem:
Boot from PXE, There should be two disk "/dev/sda" and /dev/sdb on host,Select device /dev/sda to use for booting RHEV-H, then enter into installation_device_page,select "Other Device", then click "Save" Button to configure "Other Device" into "/dev/sda,/dev/sdb".
then it will enter into installation_device_page again, but exception was thrown when clicking "Continue" button into next page.
An error appeared in the UI:ValueError("invalid literal for int() with base 10:"",)(seen valueerror exexption.png)


Version-Release number of selected component (if applicable):
rhevh-6.5-20140317.0.iso
ovirt-node-3.0.1-18.el6_5.8.noarch 


How reproducible:
100% 
  
Steps to Reproduce:
1. boot from PXE
2. Clean install rhev-h via TUI
3. Select device /dev/sda to use for booting RHEV-H
5. Enter into "installation_device_page
 select "Other Device",then click "save" Button to configure "Other Device" into "/dev/sda,/dev/sdb".
6.then it will enter into installation_device_page again, clicking "Continue" button into next page.

Actual result:
After Step 6,exception was thrown when clicking "Continue" button into next page.

Expect result:
After Step 6,no exception was thrown when clicking "Continue" button into next page.

Additional info:
No this issue in rhev-hypervisor6-6.4-20121212.1.el6 , so it's a regression bug from 6.4 into 6.5

Comment 1 haiyang,dong 2014-03-20 02:35:10 UTC
Created attachment 876697 [details]
attached Screenshot for debug console

Comment 4 Fabian Deutsch 2014-04-08 11:52:00 UTC
(In reply to haiyang,dong from comment #0)
> Description of problem:
> Boot from PXE, There should be two disk "/dev/sda" and /dev/sdb on
> host,Select device /dev/sda to use for booting RHEV-H, then enter into
> installation_device_page,select "Other Device", then click "Save" Button to
> configure "Other Device" into "/dev/sda,/dev/sdb".
> then it will enter into installation_device_page again, but exception was
> thrown when clicking "Continue" button into next page.
> An error appeared in the UI:ValueError("invalid literal for int() with base
> 10:"",)(seen valueerror exexption.png)

Please provide the exact steps one by one, I could not reproduce this issue.
Maybe because in another patch we disbaled the <save> button by default.

Can you reproduce this on the latest RHEV-H image?

Comment 5 haiyang,dong 2014-04-09 09:34:30 UTC
> 
> Please provide the exact steps one by one, I could not reproduce this issue.
> Maybe because in another patch we disbaled the <save> button by default.
> 
> Can you reproduce this on the latest RHEV-H image?

Currently the latest RHEV-H image is "rhevh-6.5-20140317.0.iso",

Steps to Reproduce:
1. boot from PXE
2. Clean install rhev-h via TUI
3. Select device /dev/sda to use for booting RHEV-H
5. Enter into "installation_device_page
 select "Other Device",then click "save" Button to configure "Other Device" into "/dev/sda,/dev/sdb".
6.then it will enter into installation_device_page again, clicking "Continue" button into next page.

Actual result:
After Step 6,exception was thrown when clicking "Continue" button into next page.

Expect result:
After Step 6,no exception was thrown when clicking "Continue" button into next page.

Comment 7 Ryan Barry 2014-04-21 17:06:19 UTC
I was just about to ask whether the ability to enter multiple devices this way was intended behavior, but it looks like it is (or was).

We probably can't fix this with a validator. If splitting the input matches the workflow in 6.4, I'm ok with that.

Comment 8 haiyang,dong 2014-04-29 05:46:15 UTC
Test version:
rhevh-6.5-20140428.0.iso 
ovirt-node-tools-3.0.1-18.el6_5.10.noarch.rpm 
ovirt-node-minimizer-3.0.1-18.el6_5.10.noarch.rpm

Test as follow:
1. Clean install rhev-h via TUI
2. Select device /dev/sda to use for booting RHEV-H
3. Enter into "installation_device_page
 select "Other Device",then click "save" Button to configure "Other Device" into "/dev/sda,/dev/sdb".
4.then it will enter into installation_device_page again, clicking "Continue" button into next page.


Test result:
After Step 4,no exception was thrown when clicking "Continue" button into next page.

so this bug has been fixed, after the status changed into "ON_QA", I will verify this bug.

Comment 10 haiyang,dong 2014-05-07 09:49:05 UTC
This bug also has been fixed in the follow version:
rhevh-6.5-20140430.0.iso
ovirt-node-3.0.1-18.el6_5.10.noarch

Comment 14 haiyang,dong 2015-01-14 08:44:01 UTC
Test version:
rhev-hypervisor6-6.6-20150112.0
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el6.noarch

Test as follow:
1. Clean install rhev-h via TUI(three disk /dev/sda,/dev/sdb,/dev/sdc in my host)
2. Select device /dev/sda to use for booting RHEV-H
3. Enter into "installation_device_page
 select "Other Device",then click "save" Button to configure "Other Device" into "/dev/sdb,/dev/sdc".
4.then it will enter the next page storage_vol_page.


Test result:
After Step 4,no exception was thrown when entering into next page.

so this bug has been fixed, change the status into "VERIFIED".

Comment 16 errata-xmlrpc 2015-02-11 20:54:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.