Bug 1078620 - database upgrade instructions for power_quiescent_period do not set the default 5 for existing rows
Summary: database upgrade instructions for power_quiescent_period do not set the defau...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: scheduler
Version: 0.16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.16.1
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-20 03:50 UTC by Dan Callaghan
Modified: 2018-02-06 00:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-26 23:54:32 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2014-03-20 03:50:40 UTC
The current database upgrade instructions for Beaker 0.16 add the new power.power_quiescent_period column (which has a Python-level default of 5, but no SQL-level default) but they fail to set the value to 5 for existing rows in the table.

Comment 1 Dan Callaghan 2014-03-20 03:51:27 UTC
Need to add:

UPDATE power SET power_quiescent_period = 5;

Comment 2 Dan Callaghan 2014-03-20 04:19:48 UTC
http://gerrit.beaker-project.org/2939

Comment 4 Dan Callaghan 2014-03-23 23:43:54 UTC
*** Bug 1079603 has been marked as a duplicate of this bug. ***

Comment 5 Dan Callaghan 2014-03-25 07:33:32 UTC
The updated instructions are now in the branch-specific docs here:

https://beaker-project.org/docs-release-0.16/whats-new/upgrade-0.16.html

Comment 6 xjia 2014-03-25 13:17:17 UTC
The document is available on page https://beaker-project.org/docs-release-0.16/whats-new/upgrade-0.16.html

Comment 7 Dan Callaghan 2014-03-26 23:54:32 UTC
Beaker 0.16.1 has been released.

Comment 8 Dan Callaghan 2014-03-27 00:04:27 UTC
Existing installations of Beaker 0.16.0 may prefer to run a conditional version of the UPDATE statement, which will avoid overwriting any quiescent period settings which have already been changed from the incorrect default 0:

    UPDATE power
    SET power_quiescent_period = 5
    WHERE power_quiescent_period = 0;


Note You need to log in before you can comment on or make changes to this bug.