Bug 107865 - Panel does not respect %f for launchers
Summary: Panel does not respect %f for launchers
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-23 20:50 UTC by Dan Williams
Modified: 2007-04-18 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 21:24:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Williams 2003-10-23 20:50:46 UTC
Creating a launcher for a small program...

When the command includes %u, the file gets passed to the program correctly as a
URL.  However, using %f instead, which according to the Freedesktop.org spec
should pass the full path to the file, fails and passes _nothing_.

Comment 1 Dan Williams 2003-10-23 20:51:35 UTC
Correction, does not fail, simply launches the program with no argument where it
should be passing the path to the file.

Comment 2 Leonard den Ottolander 2004-02-26 13:17:47 UTC
Is this still an issue with FC 1?


Comment 3 Mark McLoughlin 2004-02-27 18:13:05 UTC
Dan: just tried this out and it works fine for me. Any more details?

Comment 4 Dan Williams 2004-02-27 20:38:50 UTC
Mark, how are you testing it?

#include <stdio.h>
                                                                     
          
int main( int argc, char *argv[] )
{
        fprintf( stderr, "args: %d %s %s\n", argc, argv[0], argv[1] );
        sleep( 5 );
        exit( 0 );
}

Then, using a launcher with the command "/path/to/program %f" and
specifying "Run in Terminal", drag a document onto the launcher.  The
program pauses after printing its args.  Note that %f is (null) while
a %u actually works.

Comment 5 Dan Williams 2004-02-27 20:40:06 UTC
%f:  args: 1 /home/boston/dcbw/thing (null)
%u:  args: 2 /home/boston/dcbw/thing
file:///home/boston/dcbw/Desktop/openoffice-backtrace



Comment 6 Dan Williams 2004-02-27 20:41:29 UTC
gnome-panel-2.5.3.1-6 currently, but has existed since FC1 betas at
least, probably earlier

Comment 7 Mark McLoughlin 2004-02-27 20:47:34 UTC
Hmm, I added a launcher to the panel which pointed at as script:

#!/bin/bash

echo $@ > /tmp/t.tmp

and then tried dragging a file onto it with both %f and %u and it worked.

Could you confirm that works for you ?

Comment 8 Dan Williams 2004-02-27 21:24:27 UTC
Actual bug is becuase the gnome-desktop library uses
gnome_vfs_uri_is_local() and that makes files from NFS mounted
homedirs be skipped over.  Upstreaming this bug, gnome.org #135629

http://bugzilla.gnome.org/show_bug.cgi?id=135629


Note You need to log in before you can comment on or make changes to this bug.