Bug 1078665 - [GSS] (6.2.x) Cleanup deploy directories
Summary: [GSS] (6.2.x) Cleanup deploy directories
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Other
Version: 6.2.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR2
: EAP 6.2.3
Assignee: James Livingston
QA Contact:
Russell Dickenson
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard:
Depends On: JBPAPP6-1657
Blocks: eap62-cp03-blockers
TreeView+ depends on / blocked
 
Reported: 2014-03-20 06:56 UTC by James Livingston
Modified: 2019-03-22 07:11 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, the temporary deployment directory ('/tmp/vfs'), created while the server was running, would remain if the server stopped unexpectedly or was forcibly stopped. The directory and its contents would not be removed on a later startup. This could have serious consequences as accumulated temporary files could eventually use all available disk space. The root cause of this issue has now been resolved by adding a test on startup for temporary files. If '/tmp/vfs' is found, the directory and its contents are removed and as a result, temporary files can no longer accumulate.
Clone Of: JBPAPP6-1657
Environment:
Last Closed: 2014-06-09 12:47:27 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 270653 None None None Never
Red Hat One Jira Issue Tracker JBPAPP6-1657 Major Closed Cleanup deploy directories - AS7-6031 2019-01-11 08:57:39 UTC
Red Hat One Jira Issue Tracker WFLY-1547 Major Closed deploy directories not cleaned up 2019-01-11 08:57:39 UTC

Comment 3 Petr Kremensky 2014-05-09 06:32:45 UTC
Verified on EAP 6.2.3.CR2.

 - start standalone
 - deploy some content
 - kill -9 <standalone_PID>, start standalone, jboss-cli.sh -c shutdown
$ du -hs jboss-eap-6.2/standalone/tmp/
48K	jboss-eap-6.2/standalone/tmp/
 - start standalone, kill -9 <standalone_PID>, start standalone, jboss-cli.sh -c shutdown
$ du -hs jboss-eap-6.2/standalone/tmp/
48K	jboss-eap-6.2/standalone/tmp/
... tmp folder is properly cleaned up


Note You need to log in before you can comment on or make changes to this bug.