Bug 10787 - shutdown -h / halt bug still not fixed since version 6.0
shutdown -h / halt bug still not fixed since version 6.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-13 08:09 EDT by chumakov
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-13 11:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description chumakov 2000-04-13 08:09:16 EDT
I recently upgraded from RedHat Linux 6.0 to 6.2, expecting that the
shutdown -h / halt bug would be fixed.  I was wrong.
I have a K6-2/400 and a TMC ATX motherboard.  Every time i try to halt the
system, it spits out 2 pages of a core dump:
The system is halted.
stopping al md devices.
Power Down.

[...]
The kernel is unable to handle virtual paging request at address 0x00008885
[...]

Then it continues to dump the core.  the address 0x00008885 is the same
every time.  I don't know why it doesn't work.  Its also the same in 6.0
and 6.2.
Comment 1 Bill Nottingham 2000-04-13 11:23:59 EDT
Your BIOS is crashing after being told to power the machine
off. Your options are

a) try upgrading the BIOS
b) apply an experimental patch that switches to real mode before
   powering off (it's in 2.2.15pre18)
c) remove the '-p' from the last line of /etc/rc.d/init.d/halt,
   (this tells it not to try to power the machine off.)
Comment 2 Need Real Name 2000-08-16 20:10:23 EDT
I have the same problem, same cpu, Epox EP-MVP3G motherboard 7.16.99 Award BIOS
v4.51 PG. Maybe it is a bug in the halt code for power off for an AMD K6-2? Also
came up with the same solution (ie. remove -p from halt command).  

PS MeSsy Win98 shuts down and powers off ok (on those ever rarer occasions it
gets the opportunity).

Note You need to log in before you can comment on or make changes to this bug.