Bug 10788 - kpackage crashes when trying to uninstall certain packages
kpackage crashes when trying to uninstall certain packages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kpackage (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-13 08:47 EDT by p929001
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 15:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description p929001 2000-04-13 08:47:15 EDT
kpackage crashes when trying to uninstall certain packages. Examples are:
XFree86-libs, ncurses, zlib. What I did:

Start kpackage
Select package from examples above
Click "uninstall
"Use scripts" and "Check dependencies" checked ("Test" setting doesn't
matter)
Click OK
For some packages (e.g. XFree86-libs), kpackage crashes here
Long list of dependencies appears
Click OK
kpackage crashes

The crash seems to depend on the length of the dependency list. On my
computer (Dell Dimension XPS D333) the threshold seems to be around 15-20
entries.
Comment 1 Ngo Than 2000-10-11 10:00:42 EDT
It's fixeed in kpackage-1.3.10-6. You find it in rawhide

Note You need to log in before you can comment on or make changes to this bug.