Bug 107890 - tcp sequence number error
tcp sequence number error
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 22:38 EDT by Dongluo Chen
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 20:24:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dongluo Chen 2003-10-23 22:38:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I am working on TCP analysis. I used tcpdump to monitor a TCP connection from a 
Red Hat Linux. The sequence captured by tcpdump is as follows, where 
192.168.1.12 is a Red Hat Linux 2.4.18-3bigmem. 

02:01:02.514466 192.168.1.12.80 > 202.204.14.33.1340: P 2571840263:2571841548
(1285) ack 2400822940 win 6432 (DF) (ttl 64, id 46064, len 1325)

02:01:02.731279 202.204.14.33.1340 > 192.168.1.12.80: . [tcp sum ok] 
2400822940:2400822940(0) ack 2571841548 win 0 (DF) (ttl 114, id 3561, len 40)

02:01:03.104191 192.168.1.12.80 > 202.204.14.33.1340: . [tcp sum ok] 
2571841547:2571841547(0) ack 2400822940 win 6432 (DF) (ttl 64, id 46065, len 40)

The problem is that in the second packet, sequence number 2571841548 is 
acknowledged by the remote peer. According to my understanding of  RFC793, TCP 
should increase SND.NXT to 2571841548. But in the third packet, Linux sends out 
a window-probing packet with sequence number 2571841547. I think it is not 
conformant to RFC793 and the remote peer would just discard this packet. I 
wonder if it is a bug in the TCP implementation. Or it is designed to do this 
for some purpose. 

Thank you.


Version-Release number of selected component (if applicable):
kernel-2.4.18-3

How reproducible:
Sometimes

Steps to Reproduce:
1.Monitor tcp connections with tcpdump. (It need some tool to confirm this kind 
of trace. To reproduce this problem, send window-probing packets to a red-hat 
linux and get its response. )
2.
3.
    

Actual Results:  the sequence number in a window-probing packet is less than 
SND.NXT

Expected Results: According to my understanding of RFC793, the sequence number 
in a window-probing packet is less than SND.NXT
Comment 1 Arjan van de Ven 2003-10-24 03:14:26 EDT
You are using a very very old kernel which has been obsoleted by errata updates
many times, including kernels with tcp/ip fixes. Please verify that this is
fixed in the latest kernel erratum.

Note You need to log in before you can comment on or make changes to this bug.