Bug 1078903 - jQuery
jQuery
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Simon Clark
ChangeAcceptedF21 SystemWideChange Ch...
:
: 1078910 (view as bug list)
Depends On: 1078368 js-jquery1
Blocks: 1132725
  Show dependency treegraph
 
Reported: 2014-03-20 10:02 EDT by Jaroslav Reznik
Modified: 2016-12-09 19:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-09 19:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-03-20 10:02:32 EDT
This is a tracking bug for Change: jQuery
For more details, see: http://fedoraproject.org//wiki/Changes/jQuery

jQuery is a fast, small, and feature-rich JavaScript library. It makes things like HTML document traversal and manipulation, event handling, animation, and Ajax much simpler with an easy-to-use API that works across a multitude of browsers. With a combination of versatility and extensibility, jQuery has changed the way that millions of people write JavaScript.
Comment 1 Jaroslav Reznik 2014-03-20 10:22:37 EDT
*** Bug 1078910 has been marked as a duplicate of this bug. ***
Comment 2 Matt Moldvan 2014-05-04 23:32:23 EDT
Was just looking through the proposed system wide changes to Fedora and came across this one... how does this relate to Fedora?
Comment 3 Juha Tuomala 2014-05-11 08:46:01 EDT
I'd like to see this happen. Especially for EL repos, which should be a small effort once it's accepted for Fedora. Happy to see you guys are already on it.
Comment 4 Juha Tuomala 2014-05-11 08:51:33 EDT
Matt, read the wiki page.
Comment 5 Jaroslav Reznik 2014-07-04 06:43:28 EDT
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 6 Simon Clark 2014-08-15 09:46:31 EDT
Hello.

I put the release notes text from the change description at https://fedoraproject.org/wiki/Changes/jQuery#Release_Notes into the draft release note for Fedora 21.  Please would you take a look at https://fedoraproject.org/wiki/Documentation_Development_Web_Beat#jQuery and let me know if it is OK or if there is anything that needs to be added or changed?

Thanks.
Comment 7 Jaroslav Reznik 2014-10-07 08:23:32 EDT
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 8 Jaroslav Reznik 2014-10-20 09:25:40 EDT
Based on unfinished package reviews, moving this change to Fedora 22.
Comment 9 Jaroslav Reznik 2015-03-03 10:36:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 10 Jan Kurik 2015-07-14 10:02:38 EDT
This message is a reminder that Fedora 23 Change Checkpoint: Completion deadline (testable) is on 2015-07-28 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

This bug should be set at least to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jkurik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/23/Schedule
Comment 11 Jan Kurik 2015-08-06 05:20:11 EDT
Removing from the scope of F23 as we have already passed the deadline when this change needs to be in MODIFIED state.
Comment 12 Jan Kurik 2016-07-26 00:26:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 13 Christopher Tubbs 2016-12-09 19:52:59 EST
Closing this. It's clearly done. JQuery is provided by js-jquery1 and js-jquery, which have been available since at least F23.

Note You need to log in before you can comment on or make changes to this bug.