Bug 107907 - partitioning question asked d
Summary: partitioning question asked d
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-24 10:54 UTC by Gerald Teschl
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 10:55:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2003-10-24 10:54:42 UTC
Description of problem:
I just wanted to test nfs ks installs. I wanted to install on an existing
partition leaving my /home partition untouched. Here is the relevant
part of my ks file:

part / --onpart hda3
part swap --onpart hda2
part /home --onpart hda5 --noformat

Before installing the partition table looked as follows:

hda1 -> vfat
hda2 -> swap
hda3 -> /
hda4 -> extended
hda5 -> /home

Version-Release number of selected component (if applicable):
test 3
   
Actual results:
Anacondo stopped and offered me
1) clear all partition
2) clear all linux partitions
3) use existing partitions

I was surpriesed, that it asked questions during ks install (bug!)
but selected 3)

It then went on and seemd to be stuck at "installing packages".
Since there was no progress for several minutes, I switched to vt1
and saw that anaconda had crashed, since / was full.

Further investigation showed, that it
1) had deleted all linux partitions
2) created / as hda2 using 1 block (80MB)
3) crated swap on hda2 using 10G
4) created /home on hda5 using the remaining 5G

All partions were formatted and in particular all
data on /home was lost!

This is really BAD! 

Expected results:
anaconda should have used the existing partitions and in particular
it should not have formatted /home!



Additional info:
The same ks file worked fine with redhat 9.


Note You need to log in before you can comment on or make changes to this bug.