Bug 107917 - SQLParser QUOTED_ID does not support SQL Server quoted id's
SQLParser QUOTED_ID does not support SQL Server quoted id's
Status: NEW
Product: Red Hat Web Application Framework
Classification: Retired
Component: persistence (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-10-24 09:24 EDT by Brett Prucha
Modified: 2008-05-01 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brett Prucha 2003-10-24 09:24:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Microsoft SQL Server uses the '[' and ']' characters to quote an ID.  The 
current SQL parser only accepts the '"' character.  Not really a bug since the 
framework doesn't support SQL Server.  But to maintain compatibility with as 
many databases as possible it would be nice to have it added to the SQL Parser.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
SQL Server does support '"' as a quoted id except I ran into a problem when 
calling a stored procedure that calls "exec sp_executesql @sql" where @sql 
contains "sp_executesql N'sql statement'" where the sql statement contains the 
quoted identifier that was generated from 
com.arsdigita.persistence.InFilter.getConditions().  I modified that code to 
return "[insub]" and thats when I ran into the problem.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.