Bug 107921 - hangs when an update prerequisites a new, currently not installed package
hangs when an update prerequisites a new, currently not installed package
Status: CLOSED DUPLICATE of bug 107968
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-24 09:37 EDT by Dr. Peter Boy
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. Peter Boy 2003-10-24 09:37:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1) Gecko/20031009

Description of problem:
If you use up2date to update a currently installed package, where the newer
package on rawhide requires a package, which is curently not installed on the
system, the program hangs at the screen "testing package set / solving RPM
inter-dependencies" just before starting the progress bar to move.

The program windows will not be redrawn, if you move them around. If you try to
close the window, you get a message: "window does not react" (bad retranslation
into english) and you have to choose a forced kill.

Version-Release number of selected component (if applicable):
up2date-4.1.9-1

How reproducible:
Always

Steps to Reproduce:
1. Start to installe Fedora Core Test 3 with a standard system. Include abiword
(2.0.0-3 from CD) and include librsvg2 (from CD). Make shure that libcroco is
not installed (is not required by abiword or librsvg2 on the installation CD) 
2. Update up2date to version 4.1.9-1
3. Start up2date and try to update abiword (2.0.0-6) and/or librsvg2 (2.4.0-2)

    

Actual Results:  The up2date program will hang shortly after displaying the
window "testing package set / solving RPM inter-dependencies" and before the
progress bar moves on.

Expected Results:  up2date should update abiword and/or librsvg2

Additional info:

if you manually install the package libcroco from the installation image, you
can update both abiword and librsvg2 as usual. 

The newer versions of abiword/librsvg2 depend on libcroco, the older ones do not
(so libcrco is not installed during the installation of test 3).
Comment 1 Dr. Peter Boy 2003-10-25 20:50:31 EDT
version 4.1.10-1 suffers from this bug, too. The only difference: the window is
redrawn, if you move it around. 
Comment 2 Dan 2003-10-28 13:32:34 EST
doesn't work for Athlon based processors hangs on "testing package set / solving
RPM inter-dependencies" but was able to install on my PIII laptop after waiting
5 or so minutes at that dialog box.
up2date-4.1.12-1
may not be able to install all packages at a time might have to install a couple
at a time, amd that is very annoying :{
Comment 3 Dan 2003-10-28 13:42:55 EST
Yeah seperating the download worked.
It just didn't like all those files at one time.
Very annoying indeed
Comment 4 Dr. Peter Boy 2003-10-30 09:21:15 EST
version 4.1.12-1 didn't solve the problem, according to my testing.

Given the rawhide status Oct. 29, 2003 you can't update all rawhide packages, if
on the system w3c-libwww, which delivers libmd5, being installed, which is
needed by one of  the packages (if I remember correctly redhad-config-*). As
soon as you install w3c-libwww up2date works.

version 4.1.12-1 also hangs in case You select a package for update which
depends on a updated package, which is not selected. Given rawhide Oct. 29 you
can test by trying to update the gcc* packages without selecting the
corresponding lib* packages, too.
Comment 5 Marc Payne 2003-10-31 01:53:38 EST
This problem still doesn't seem to be fixed in 4.1.14-2.  It seems the problem
lies in the package dependency checking, because that's usually where up2date hangs.

You know what I think? I think some developer slipped an infinite loop or pause
statement into up2date!  (hehe, just kidding)  ;-)

I really hope this problem is resolved before the November release of Fedora.
Comment 6 Aleksey Nogin 2003-12-10 14:40:44 EST
Up2date does not hangs, it just attempts to download _all_ header
files for _all_ available packages. This only happens the first time
around (it  caches the headers it downloaded). This is a deficiency of
the Yum protocol, not up2date's fault - see bug 107968. Also see bug
108814 which asks for a progress bar (to combat the "it just hangs"
perception).

*** This bug has been marked as a duplicate of 107968 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:59:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.