Bug 1079225 - Graphs of sub-level resources in groups fail.
Summary: Graphs of sub-level resources in groups fail.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core UI, Resource Grouping
Version: 4.10
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: GA
: RHQ 4.12
Assignee: Jay Shaughnessy
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-21 09:00 UTC by Stian Lund
Modified: 2014-12-15 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-15 11:36:38 UTC


Attachments (Terms of Use)
Logs and screenshots. (209.95 KB, application/zip)
2014-03-21 09:00 UTC, Stian Lund
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 980765 None None None Never

Internal Links: 980765

Description Stian Lund 2014-03-21 09:00:28 UTC
Created attachment 877164 [details]
Logs and screenshots.

Description of problem:

Sub-level resources of compatible groups fail to render in the new graphs, 
since they were introduced in 4.8.

The graph window just shows up empty, not rendering the graphs.
This happens regardless of size of group, just two grouped resources is enough.

Attaching screenshots to show the problem as well as logs from RHQ server.
I can attach debug logs from Firebug if wanted.

Reproduced in Firefox 25 and Chrome 25. 
Tried to clear all browser cache and history.

This has been discussed (and debugged) at length in:
https://bugzilla.redhat.com/show_bug.cgi?id=980765

Figured it better to open a new BZ for this specific problem.

Version-Release number of selected component (if applicable):

RHQ 4.10
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Linux d26apvl007.test.local 2.6.32-358.23.2.el6.x86_64 #1 SMP Sat Sep 14 05:32:37 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Reproducible.

Steps to Reproduce:
1. Create a recursive compatible groups containing resources with metric data in top-level and sub-levels.
2. Open group and click on top-level graph, works.
3. Go to sub-level group and click on graph, window is empty.

Actual results:

Expected results:

Additional info:

Have tried to create a group and reproduce, then remove one of the two members so only one graph. Still fails for sub-levels.

Comment 1 Stian Lund 2014-03-24 07:59:51 UTC
@Heiko, Mike T:

Could the lack of time specification on the failing graph "window" be a clue to the cause? I notice for the working graph (RHQ-Test-Toplevel) it specifies "A day" while there's nothing for the second.

Comment 2 Stian Lund 2014-04-22 10:59:54 UTC
Hello!
Has anyone been able to have a look at this? Specifically Mike T? :)

Comment 3 Stian Lund 2014-05-14 09:14:11 UTC
Still present in 4.11 :(

Is anyone looking at this at all any more?

thanks,
Stian

Comment 4 Stian Lund 2014-05-22 09:10:28 UTC
Just a small ping to Mike - just wondering if there's been any progress at this graphing bug? Maybe possible to get something to test for 4.12?

Sorry for being forward, this is just the only showstopper bug for us migrating from 4.5.1 to 4.12.

Stian

Comment 5 Mike Thompson 2014-05-22 15:16:20 UTC
Hi Stian,

Its good of you to bring it up as I have actually forgot about this. I will bring this issue up for triage and get back to you with an anwser.

-- Mike

Comment 6 Jay Shaughnessy 2014-05-23 20:42:12 UTC
I reproduced and will take a stab at it...

Comment 7 Jay Shaughnessy 2014-05-27 16:30:17 UTC
master commit b6b7eeedb60e4275f2bfc51cb479f639423efe3e
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Tue May 27 12:27:05 2014 -0400

    API's dealing with Resource Groups should typically handle all 3 types of
    resource groups: standard, autogroup and autoclusters.  The way to do this
    is to use an EntityContext in the API.  In this case we were ignoring
    autoclusters.  This fix converts a few group-related APIs to use
    EntityContext. It simplifies the APIs, fixes this bug and likely fixes
    a few other problems.

Comment 8 Stian Lund 2014-06-01 09:27:49 UTC
This sounds like very good news :)

Jay, I'll be happy to test on my end if the fix is included in one or more jars I can replace without building a completely new install.

Let me know if I can help.

Comment 9 Jay Shaughnessy 2014-06-02 15:14:53 UTC
Hi Stian,

If you'd like to try it out before the 4.12 release you can do so by building from the master branch for rhq-project in github.

If you want only to build specific modules for an existing dev-container you'd need to rebuild:
modules/enterprise/server/jar
modules/enterprise/gui/coregui
modules/enterprise/gui/portal-war

We don't really publish test jars or nightly builds, sorry.

Comment 10 Stian Lund 2014-06-02 15:36:26 UTC
Hello Jay,
I've not gotten my head around Git and building stuff yet. Maybe one day :)
Also I am behind a firewall at work so using public Git is not so easy.

I will wait for 4.12 - hopefully it will be out soon :)

Comment 11 Stian Lund 2014-08-07 08:14:45 UTC
Verified that this bug with sub-level groups are now gone. 

Thanks for the fix!

Comment 12 Jay Shaughnessy 2014-08-07 13:18:55 UTC
Stian, thanks for the feedback!  I'll move this to VERIFIED given your qualification.

Comment 13 Heiko W. Rupp 2014-12-15 11:36:38 UTC
Bulk close of items fixed in RHQ 4.12

If you think this is not solved, then please open a *new* BZ and link to this one.


Note You need to log in before you can comment on or make changes to this bug.