Bug 107925 - rpm -qa and rpm --rebuilddb both segfault
Summary: rpm -qa and rpm --rebuilddb both segfault
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-24 16:17 UTC by Mike Frisch
Modified: 2007-04-18 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-11 13:46:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Frisch 2003-10-24 16:17:22 UTC
Description of problem:

rpm -qa and rpm --rebuilddb both segfault.

Many messages output like:

error: rpmdbNextIterator: skipping h#     601 Header V3 DSA signature: BAD, key
ID db42a60e

Version-Release number of selected component (if applicable):

rpm-4.1.1-1.8x

(Installed based on the advice found at www.rpm.org)

How reproducible:

Happens consistently.

Steps to Reproduce:

Unfortunately, I am unsure how the database corruption occurred, but it was
working flawlessly until it stopped working.

I attempted to fix the problem by installing the newer version of rpm from
www.rpm.org, but to no avail.

Comment 1 Mike Frisch 2003-10-24 16:23:26 UTC
You can get a copy of my /var/lib/rpm from
http://www.isurfer.ca/~mfrisch/rpmdb.tar.gz

Comment 2 Brad Cox 2003-11-21 01:29:57 UTC
Happens here too 
 
[bcox@linux lib]$ sudo rpm --rebuilddb 
error: rpmdbNextIterator: skipping h#     900 Header V3 DSA signature: BAD, 
key ID 66534c2b 
---repeated ~200 times --- 
Segmentation fault 
 
Vanilla RH8.0 system, updated via up2date and yum. No recent crashes until 
this. 100% reproducible. 

Comment 3 Brad Cox 2003-11-21 01:32:37 UTC
Oh yes, this symptom is widely reported (google rpmdbNexIterator skipping). 
Suggested cause is DSA certificate expiration. Someone suggested 
rpm -i /usr/share/doc/redhat-release-8.0/RPM-GPG-KEY, but that doesn't work 
either. rpm barfs on non-key header text in that file. 

Comment 4 Brad Cox 2003-11-29 17:27:24 UTC
Problem was fixed by

rm /var/lib/rpm/PublicKeys
rpmdb --rebuilddb

No idea what caused it. Possibly used rpm -i /usr/share/whatever/it/was/*GPG* 
when rpm --import was intended.


Note You need to log in before you can comment on or make changes to this bug.