Bug 107930 - libgcj requires /sbin/install-info
libgcj requires /sbin/install-info
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-24 12:59 EDT by Forrest
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-24 21:24:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that adds /sbin/install-info as a Prereq of libgcj (260 bytes, patch)
2003-10-24 13:03 EDT, Forrest
no flags Details | Diff

  None (edit)
Description Forrest 2003-10-24 12:59:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20031017

Description of problem:
I have been trying to install an oscar cluster, which has been bombing out
because libgcj %post scripts could not run:

/var/tmp/rpm-tmp.98116: line 3: /sbin/install-info: No such file or directory
error: %post(libgcj-3.2.3-16) scriptlet failed, exit status 127

Adding:

Prereq: /sbin/install-info
Autoreq: true

to the libgcj section of the spec file seems to fix it.

Version-Release number of selected component (if applicable):
gcc-3.2.3-16

How reproducible:
Always

Steps to Reproduce:
1.  Install libgcj before info


Actual Results:  %post script of libgcj failed because of a dependency on
/sbin/install-info
Comment 1 Forrest 2003-10-24 13:03:24 EDT
Created attachment 95460 [details]
Patch that adds /sbin/install-info as a Prereq of libgcj
Comment 2 Brent Fox 2004-07-24 21:24:54 EDT
It looks like the Prereq for /sbin/install-info in the libgcj section
of gcc33.spec is there in the gcc-3.3.3-7 SRPM.  Closing as
'currentrelease'.

Note You need to log in before you can comment on or make changes to this bug.