SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1079546 - Child history view hangs when "Past N Days Filter" has empty value
Summary: Child history view hangs when "Past N Days Filter" has empty value
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR01
: JON 3.2.2
Assignee: Thomas Segismont
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-21 19:22 UTC by Matt Mahoney
Modified: 2014-07-29 00:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 00:17:16 UTC
Type: Bug


Attachments (Terms of Use)
Past N Days - Empty Value (27.21 KB, image/png)
2014-03-21 19:22 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-03-21 19:22:49 UTC
Created attachment 877467 [details]
Past N Days - Empty Value

Description of problem:
When attempting to do a "Past N Days" filter/search with a empty/blank filter value, the filter/search appears to hang and displays the following banner:

 "Failure in datasource while processing FETCH request."

The "Loading..." progress indicator does not appear to time-out.

Version-Release number of selected component (if applicable):
3.2.2

How reproducible:
Always

Steps to Reproduce:
1. Navigate to "Postgres.Inventory."
2. Create various new User Resources.
3. Click Child History
4. Delete any value that may be in "Past N Days" entry box, and then hit return.

Actual results:
Attempting to search Past N Days with empty value, results in filter/search hang.

Expected results:
Filter/Search should not hang when Past N Days does not contain a value.

Additional info:

Comment 1 Thomas Segismont 2014-05-12 11:35:19 UTC
Fixed in master

commit bc8b90d03a6e6533b65879702936c787a35f3063
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon May 12 13:30:54 2014 +0200

Use DateFilterItem instead of "Past N days" SpinnerItem
Use Countdownlatch instead of nested GWT async service calls
Handle parse error and null dates

Comment 2 Thomas Segismont 2014-05-12 11:45:39 UTC
Cherry-picked over to release/jon3.2.x

commit 331a0271d864930d67a0339d8ab8bba0984d480b
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon May 12 13:30:54 2014 +0200

Comment 3 Simeon Pinder 2014-05-22 15:15:39 UTC
Via product triage, determined that this bug is to be included for DR01 target milestone.

Comment 4 Thomas Segismont 2014-05-22 15:52:51 UTC
Changed the title and component because this is not a Postgres plugin bug, but really a general CoreGUI issue with the Child History view

Comment 5 Thomas Segismont 2014-05-22 15:56:58 UTC
Removed dependency on Postgres plugin bugs tracker (Bug 1082792), this is a UI bug

Comment 6 Simeon Pinder 2014-05-30 02:43:37 UTC
Moving to ON_QA as available for test in latest cumulative patch build(DR01):
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.2.2.GA/5-29-2014/

Comment 7 Matt Mahoney 2014-05-30 19:10:48 UTC
Tested against JON 3.2.0 GA + CP2 (DR1)

Comment 8 Larry O'Leary 2014-07-29 00:17:16 UTC
This has been verified and released in Red Hat JBoss Operations Network 3.2 Update 02 (3.2.2) available from the Red Hat Customer Portal[1].



[1]: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=31783


Note You need to log in before you can comment on or make changes to this bug.