Bug 1079586 - xsane starts with a lot of error messages, and doesn't load saved configuration parameters
Summary: xsane starts with a lot of error messages, and doesn't load saved configurati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xsane
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-21 21:59 UTC by xvr
Modified: 2014-04-15 15:50 UTC (History)
4 users (show)

Fixed In Version: xsane-0.999-12.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-15 15:32:09 UTC


Attachments (Terms of Use)

Description xvr 2014-03-21 21:59:34 UTC
Description of problem:
xsane starts with 12 x the error message "Failed to create directory: File exists", each one in a separate dialog box with a "Close" button.
Then the error message "Error while loading device settings. /home/ribesx/.sane is not a device-rc-file !!!"
Saved configuration parameters are not loaded.
The application is hardly usable because no parameter is retained. Each time an option is modified the error message "Failed to create directory..." pops up.
When quitting xsane, a few "Failed to create directory..." are displayed. No parameter is saved.

Version-Release number of selected component (if applicable):
xsane 0.999-10.fc20 (latest update as of 2014/03/21)

How reproducible:
always

Steps to Reproduce:
1.start xsane
2.quit xsane
3.

Actual results:
application hardly usable

Expected results:
application should work like previous version 0.999-7

Additional info:
the problem is the same under Gnome or KDE

Comment 1 Joachim Backes 2014-03-25 07:15:59 UTC
same here (xsane-0.999-10.fc20.x86_64)

Comment 2 Hilary Wright 2014-03-28 07:51:08 UTC
I have exactly the same error. F20 new install 3 days ago.
(xsane-0.999-10.fc20.x86_64)

Comment 3 Sammy 2014-03-28 12:52:44 UTC
Ditto...pretty much unusable,

Comment 4 Nils Philippsen 2014-03-28 14:49:06 UTC
It seems I overshot the mark with one of the patches in these testing updates:

https://admin.fedoraproject.org/updates/FEDORA-2014-4128/xsane-0.999-10.fc20
https://admin.fedoraproject.org/updates/FEDORA-2014-4132/xsane-0.999-10.fc19

In the future, additionally to filing a bug, please leave negative karma on the respective update(s). Thanks!

Comment 5 Fedora Update System 2014-04-02 14:37:56 UTC
xsane-0.999-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-4132/xsane-0.999-11.fc19

Comment 6 Fedora Update System 2014-04-02 14:37:57 UTC
xsane-0.999-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-4128/xsane-0.999-11.fc20

Comment 7 Fedora Update System 2014-04-03 04:05:49 UTC
Package xsane-0.999-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xsane-0.999-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4128/xsane-0.999-11.fc20
then log in and leave karma (feedback).

Comment 8 Hilary Wright 2014-04-08 12:29:31 UTC
Hello, I finally installed the new version in updates-testing, v12 and the problem of error messages has disappeared.

Thanks for your help.

Comment 9 Fedora Update System 2014-04-15 15:32:09 UTC
xsane-0.999-12.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-04-15 15:50:26 UTC
xsane-0.999-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.