Bug 107962 - No sound with SIS Integrated sound controller
No sound with SIS Integrated sound controller
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-24 21:21 EDT by Aldert E. van der Laan
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 00:26:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aldert E. van der Laan 2003-10-24 21:21:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
Hardware: ASUS P4S533-X with 3Ghz processor. APIC and ACPI detected and loaded,
routing works.  I hear a loud click after logging in and no sound at all.

Kernel 2.4.22-1.2105.nptlsmp and the no smp kernel same result.

Hyperthreading off and on makes no difference

lspci -vvv

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)
        Subsystem: Asustek Computer, Inc.: Unknown device 80b0
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (13000ns min, 2750ns max)
        Interrupt: pin C routed to IRQ 10
        Region 0: I/O ports at 9400 [size=256]
        Region 1: I/O ports at 9000 [size=128]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=55mA
PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


Modules.conf:

alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

Dmesg output:
Intel 810 + AC97 Audio, version 0.24, 22:05:18 Oct 21 2003
i810: SiS 7012 found at IO 0x9000 and 0x9400, MEM 0x0000 and 0x0000, IRQ 10
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
ac97_codec: AC97 Audio codec, id: ADS112 (Unknown)
i810_audio: AC'97 codec 0 supports AMAP, total channels = 6
spurious 8259A interrupt: IRQ7.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Installing OS
2.
3.
    

Actual Results:  No sound - Rest of system working flawless

Expected Results:  Listen to some good music and sound themes

Additional info:

No issues with the other "OS"

Soundcard is produced by Soundmax
Comment 1 Aldert E. van der Laan 2003-10-26 09:21:41 EST
Installed ALSA for now without issues.  Bug should hopefully be fixed before the
next release, will keep you posted if things improve with the updates. [AEL]
Comment 2 Aldert E. van der Laan 2003-11-09 23:09:22 EST
Since Fedora Core 1 is now official I need to get a work around.  I
reinstalled FC1 clean and no sound.  I did read that plugging in the
sound in the microphone jack would produce sound with OSS.  I tried it
and it worked, however I can not dive under my desk constantly when
switching from one OS to another to get sound.  It has become a little
annoying and I have tried to recompile the Alsa drivers without success.
Alsa also doesn't seem to be supported in KDE? - Aldert -
Comment 3 Dave Jones 2004-12-08 00:26:45 EST
fc1 - eol

Note You need to log in before you can comment on or make changes to this bug.