Bug 1079621 - Incorrect package count when some packages already downloaded
Summary: Incorrect package count when some packages already downloaded
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-22 05:52 UTC by Ben Boeckel
Modified: 2014-09-30 23:42 UTC (History)
4 users (show)

Fixed In Version: dnf-0.4.19-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 08:13:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Boeckel 2014-03-22 05:52:39 UTC
dnf-0.4.18-1.fc21.noarch

When skipping a package because it is already downloaded, the "downloaded" count should be increased or the "total" count should be decreased.

Install  7 Packages

Total size: 10 M
Total download size: 9.8 M
Installed size: 39 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] ldc-config-2-57.20140305git6e908ff.fc21.noarch.rpm: Already downloaded
[SKIPPED] libconfig-1.4.9-5.fc21.x86_64.rpm: Already downloaded
[SKIPPED] ldc-druntime-devel-2-57.20140305git6e908ff.fc21.x86_64.rpm: Already downloaded
[SKIPPED] ldc-druntime-2-57.20140305git6e908ff.fc21.x86_64.rpm: Already downloaded
(1/7): ldc-phobos-devel-2-57.20140305git6e908ff.fc21.x86_64.rpm                            156 kB/s | 1.0 MB     00:06
(2/7): ldc-phobos-2-57.20140305git6e908ff.fc21.x86_64.rpm                                  161 kB/s | 1.7 MB     00:10
(3/7): ldc-2-57.20140305git6e908ff.fc21.x86_64.rpm                                         354 kB/s | 5.4 MB     00:15
--------------------------------------------------------------------------------------------------------------------------
Total                                                                                      628 kB/s |  10 MB     00:17

Comment 1 Ales Kozumplik 2014-03-24 08:17:16 UTC
Fixed by 7209092 on master.

Comment 2 Fedora Update System 2014-03-24 09:05:50 UTC
dnf-0.4.19-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.19-1.fc20

Comment 3 Fedora Update System 2014-03-25 08:13:28 UTC
dnf-0.4.19-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.