Bug 1079635 - Use system libedit instead of bundled one
Use system libedit instead of bundled one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: OpenIPMI (Show other bugs)
22
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Boris Ranto
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DuplicSysLibsTracker 1075696
  Show dependency treegraph
 
Reported: 2014-03-22 07:15 EDT by Ville Skyttä
Modified: 2015-11-24 15:33 EST (History)
2 users (show)

See Also:
Fixed In Version: OpenIPMI-2.0.21-4.fc22.src.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 15:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use system libedit instead of bundled one (47.39 KB, patch)
2014-03-22 07:15 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2014-03-22 07:15:11 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

'git am'able fix attached, build tested only. Let me know if you'd
like me to push and build this for devel. Also contains the following
"while at it" fixes:

- Drop no longer needed aarch64 hacks
- Package all installed files (#1075696)
- Don't ship lanserv files in main package
Comment 1 Ville Skyttä 2014-03-22 07:15:16 EDT
Created attachment 877575 [details]
Use system libedit instead of bundled one

- Drop no longer needed aarch64 hacks
- Package all installed files (#1075696)
- Don't ship lanserv files in main package
Comment 2 Ales Ledvinka 2014-08-12 08:46:06 EDT
Could you please elaborate why is the patch dropping the aarch64 and lanserv.

Fixed the library duplication.
Comment 3 Ville Skyttä 2014-08-14 04:21:02 EDT
(In reply to Ales Ledvinka from comment #2)
> Could you please elaborate why is the patch dropping the aarch64 and lanserv.

It is not dropping aarch64 and lanserv. As noted in the initial comment:

"Drop no longer needed aarch64 hacks" -- it is dropping a hack that is no longer needed, it is automatically handled by the %configure macro. More details in bug 951442.

"Don't ship lanserv files in main package" -- lanserv files are already included in the -lanserv subpackage, no need to include them in the main package as well.

Regarding the libedit changes made, "Requires: libedit" is superfluous and should be removed, it's taken care of by an automatic dependency on the actual lib.
Comment 4 Jaroslav Reznik 2015-03-03 11:59:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 5 Fedora Admin XMLRPC Client 2015-11-05 03:31:02 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2015-11-05 05:13:28 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Boris Ranto 2015-11-24 15:33:25 EST
I removed the duplicate files in the file lists. However, we need to run the autotools bits in order to generate the new configure script as we removed the libedit directory and the configure script would fail otherwise. I have updated the comments regarding this accordingly.

Note You need to log in before you can comment on or make changes to this bug.