Bug 1079639 - tnftp bundles libedit
tnftp bundles libedit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tnftp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-03-22 07:39 EDT by Ville Skyttä
Modified: 2014-06-25 14:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: tnftp-20130505-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 14:53:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2014-03-22 07:39:32 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

tnftp uses a bundled copy of libedit, it should be fixed to use the system one.

$ repoquery --repoid=rawhide-debuginfo -l tnftp-debuginfo | grep libedit
Comment 1 David Cantrell 2014-06-25 14:53:35 EDT
Fixed.  Due to the structure of the tnftp source tree, it's best to leave the libedit subdirectory in there because it contains headers from NetBSD that help drive the compilation of tnftp.  But I've patched src/Makefile.in to use the system libedit.

Note You need to log in before you can comment on or make changes to this bug.