Bug 107969 - i2c modules are not included
Summary: i2c modules are not included
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-25 10:53 UTC by Dirk Gfroerer
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 20:08:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dirk Gfroerer 2003-10-25 10:53:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030910

Description of problem:
Configuration of lm_sensors fails, since i2c modules are not included in the
kernel RPM. However they're configured in the SRPM.


Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. rpm -q -l kernel-2.4.21-4.EL |fgrep i2c

    

Actual Results:  No i2c modules are found.

Expected Results:  i2c modules are installed.

Additional info:

Kernel RPM is kernel-2.4.21-4.EL.i686.rpm

Comment 1 Arjan van de Ven 2003-10-25 11:02:11 UTC
they'll be in the kernel-unsupported rpm....


Comment 2 Dirk Gfroerer 2003-10-25 11:16:45 UTC
Installing the kernel-unsupported rpm resolved the problem.

However will I loose support for the machines, I install the kernel-unsupported
rpm? I really like the feature to remote monitor the temperature of the
machines. Already saved us from a crash in the past when the CPU cooler started
to fail.

Perhapse a dependendcy should be added to the lm_sensors package.


Comment 3 Arjan van de Ven 2003-10-25 11:20:37 UTC
Not for the machine afaik (but read the SLA text to be 100% sure). We don't
provide active support for the modules in the -unsupported rpm (eg we reserve
the right to not spend lots of time debugging a module in it) and if there's an
issue where it's suspected that a module from this rpm is causing trouble, you
may be asked to try to reproduce it without said module loaded. 


Note You need to log in before you can comment on or make changes to this bug.