Bug 107971 - gdmflexiserver (with '-n' option) kills X session
Summary: gdmflexiserver (with '-n' option) kills X session
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-25 11:33 UTC by Joel Barrios
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 23:20:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joel Barrios 2003-10-25 11:33:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014
Epiphany/1.0.1

Description of problem:
gdmflexiserver -n :1
gdmflexiserver -n

While trying to start gdmflexiserver into a nested window with '-n'option, it
killed X session. Xnest works ok by itself, so it seems to be a gdm problem.
Tested on three machines, with several theme gdmgreeter/gdmlogin combinations
with same results (BTW, gdmsetup does not run from gdmgreeter/gdmlogin).

No debug info available [at least that could be found], except for some stuff in
/var/log/messages:

Oct 24 02:22:05 linux gdm[21208]: GDM file gdm.c: line 2849 (N/A): Cannot run
setegid to 42
Oct 24 02:22:05 linux gdm(pam_unix)[21263]: session closed for user my-user-name

Those two lines were logged each time I tested 'gdmflexiserver -n :1'

Software used:
        Fedora Core 0.95
        gdm-2.4.4.5-1
        XFree86-4.3.0-40
        nvidia_drv from NVIDIA-Linux-x86-1.0-4496
        nv_drv driver from XFree86-4.3.0-40

Kernels used:
        2.4.22-1.2088.nptl
        2.4.22-1.2096.nptl
	2.4.22-1.2105.nptl
        2.4.20-20.9

Hardware:
        nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
        nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)
        nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]
        (rev 15)



Version-Release number of selected component (if applicable):
gdm-2.4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1. run gdmflexiserver -n or gdmflexiserver -n :1 from any X session (GNOME,
Failsafe, etc)
    

Actual Results:  X Session is terminated

Expected Results:  To open a nested gdm

Additional info:

Comment 1 Ben Liblit 2004-01-27 13:09:55 UTC
This might correspond to GNOME bug report
<http://bugzilla.gnome.org/show_bug.cgi?id=127780>, in which case it
has already been fixed upstream.

Comment 2 Warren Togami 2004-02-05 02:11:21 UTC
Please locate the exact cvs commit URL containing this fix and it will
be considered for review in the future.

Comment 3 Warren Togami 2004-11-27 23:20:02 UTC
Fixed a while ago.


Note You need to log in before you can comment on or make changes to this bug.