Bug 107987 - up2date --hardware fails on Toshiba Tecra 8100
up2date --hardware fails on Toshiba Tecra 8100
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
:
Depends On:
Blocks: 120092
  Show dependency treegraph
 
Reported: 2003-10-25 13:57 EDT by Alexandre Oliva
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of DMI on Supermicro X5DPI board (13.55 KB, text/plain)
2004-08-13 07:08 EDT, Jon. Hallett
no flags Details

  None (edit)
Description Alexandre Oliva 2003-10-25 13:57:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031023

Description of problem:
It seems that up2date has its own copy of dmi-reading code, because even though
dmidecode succeeds, up2date --hardware prints:
Reading DMI info failed

Sure enough, strace reveals it's using an up2date-owned dmimodule.so library,
that fails in just the same way as the as pre-2.2 dmidecode did.

See bug 84723 for more on the dmidecode story.

Version-Release number of selected component (if applicable):
up2date-4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1.Run dmidecode
2.Run up2date --hardware on a Toshiba Tecra 8100 with latest BIOS updates.

Actual Results:  dmidecode succeeds, but up2date --hardware fails to read DMI info.

Expected Results:  I'd expected that, if one succeeded, so would the other.

Additional info:
Comment 1 Jon. Hallett 2004-08-13 07:08:20 EDT
Created attachment 102694 [details]
Output of DMI on Supermicro X5DPI board

I'm seeing the same problem with up2date on a dual processor Xeon box with a
Supermicro X5DPI mainboard.

up2date --hardware does this:

[root@wren root]# up2date --hardware
Updating hardware profile...
Reading DMI info failed

The dmidecode command itself works fine (output attached), though there is a
field listed as <OUT OF SPEC>, which doesn't look right.

[root@wren root]# uname -a
Linux wren 2.4.21-4.ELsmp #1 SMP Fri Oct 3 17:52:56 EDT 2003 i686 i686 i386
GNU/Linux
[root@wren root]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon)
[root@wren root]# rpm -qa | grep up2date
up2date-4.2.33-1
up2date-gnome-4.2.33-1
Comment 2 RHEL Product and Program Management 2007-10-19 15:33:41 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.