Bug 1079956 - missing dependency
Summary: missing dependency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-hosted-engine-setup
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: meital avital
URL:
Whiteboard: integration
Depends On:
Blocks: 1123213
TreeView+ depends on / blocked
 
Reported: 2014-03-24 11:52 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:56 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:41:16 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26084 master MERGED Fix setup of additional host - it used the old backend API Never

Description Jiri Moskovcak 2014-03-24 11:52:26 UTC
Description of problem:

Just run:
$ hosted-engine --deploy --config-append=answers.conf 
***L:ERROR Internal error: No module named storage_backends


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.2.0-0.0.master.20140324112909.gitc0e9c96.fc19.noarch

How reproducible:
100%

Comment 1 Jiri Moskovcak 2014-03-24 11:55:53 UTC
It seems that the latest setup depends on the feature added recently to the hosted-engine-ha in the commit:

commit de329b53ee4ca5bc5b40cfefea541c4515b3bf13
Author: Martin Sivak <msivak@redhat.com>
Date:   Mon Mar 17 16:11:03 2014 +0100

    Add metadata storage support for raw block device

Comment 2 Sandro Bonazzola 2014-03-24 12:07:40 UTC
This is due to build error on Jenkins, so nightly build for HA has not been published.
Martin, Greg, please bump HA to 1.2.0-0.1 so I can add a Require on a newer version of the HA package.

Comment 3 Sandro Bonazzola 2014-10-17 12:41:16 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.