Bug 108 - Boot Image does not support international character sets
Boot Image does not support international character sets
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
All Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-17 14:05 EST by ukdavidw
Modified: 2015-11-18 16:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 18:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ukdavidw 1998-11-17 14:05:24 EST
Its kinda silly really, but there IS life outside the US,
and we don't all use NLS Codepage 850.  UK formatted hard
disks use cp 437, but there is no support for this in the
installation boot image.  This needs to be added, or an
international image made available.
This only applies do installations performed from
downloaded files, UK-written CDs and locally mounted
network drivs.
Comment 1 David Lawrence 1998-11-19 11:13:59 EST
It would be helpful to know how the CD was created and what settings
were used to create it. It sounds like the CD may have been burned
incorrectly.
Comment 2 ukdavidw 1998-11-20 01:39:59 EST
The CD was created with Adaptec Toast on a macintosh.  THe format used
was ISO9660 with Joliet extensions.
The hard disk installation (which also failed) is a Win98 machine
(urgh!) with FAT32.  It is a UK installatio
Comment 3 David Lawrence 1998-11-20 10:34:59 EST
We do not have any experience with Adaptec Toast application. We use
the GPL utility called cdwrite. I feel it may be a configuration
problem with the app you are using. Can you try not using Joliet
extensions and burn it straight iso9660 with Rock Ridge extensions.
Also with hard drive installs, if it is having difficulty finding the
directory on the FAT32 partition, we know this to be a problem and are
working on finding a solution. Possible work arounds for this are
using a boot and rescue disk and mount the vfat partition, make sure
that they rpms directory is capital RPMS not lowercase and make sure
the redhat directory is RedHat.
Comment 4 ukdavidw 1998-11-20 11:23:59 EST
Unfortunately Adaptec Toast doesn't write Rock Ridge CDs so I can't
try that.  I'll try to get hold of a new package on Monday and see
what happens.
With regards to the hard disk installation, the installation program
fails because it cannot find the NLS support for the disk... the RPMS
directory is named in upper case and the redhat directory is spelled
with a capital R and H.
I'll try the boot and rescue solution later and post the results.
Comment 5 ukdavidw 1998-11-20 13:16:59 EST
Hard disk installation from the UK Win98 machine failed again with
the same message.  Booting to the rescue set and trying to mount the
Hard Disk resulted in "Unable to load NLS Charset cp437(nls_cp437)"
Trying to load the CD resulted in a failure to load iso9660
extensions - the rescue set does not seem to have support for CDs.
Comment 6 Matt Wilson 1998-11-20 17:14:59 EST
The current architecture of the installer does not allow us to make
the loading of nls codepages easy.  We've changed this for the next
release.
Comment 7 ukdavidw 1998-11-22 11:51:59 EST
Does this mean that international customers cannot install 5.2 from a
hard disk image?
Comment 8 zblaxell 1998-11-23 23:58:59 EST
Debian provides official CD images that you can download and burn onto
CD-R's.  I can point a Win95 user with a CD writer to Debian and say
"download this image file, rename it something.ISO, burn it onto a
CD-RW, and boot from it."  The Win95 user then does all this and says
"Wow, I never imagined it was so easy to install Linux."  OK, maybe
I'm paraphrasing liberally here, but you get the point:  burning a
bootable Debian CD is literally two drag-and-drop operations from a
web browser to local hard disk to a CD writer under Win95.

Needless to say, such convenience is conspicuously missing from Red
Hat's FTP site.  ;-)
Comment 9 Preston Brown 1999-03-18 10:12:59 EST
Matt, have all codepage issues been resolved?  If so, please close
this bug.
Comment 10 Bill Nottingham 1999-07-15 18:14:59 EDT
This was fixed in the errata boot images for 6.0, IIRC.

Note You need to log in before you can comment on or make changes to this bug.