Bug 1080480 - qpid-config does not support int arguments
Summary: qpid-config does not support int arguments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools
Version: 3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: 3.1
: ---
Assignee: Pavel Moravec
QA Contact: Eric Sammons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-25 14:09 UTC by Zdenek Kraus
Modified: 2015-04-14 13:47 UTC (History)
5 users (show)

Fixed In Version: qpid-tools-0.30-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch proposal (693 bytes, patch)
2014-03-25 14:14 UTC, Zdenek Kraus
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5945 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Zdenek Kraus 2014-03-25 14:09:44 UTC
Description of problem:
qpid-config handles all arguments as string, no allowing a int value for int options, making for example Amqp 1.0 topics with string queue arguments (qpid.max_count = '5')

Version-Release number of selected component (if applicable):
qpid.-tools-0.22-9

How reproducible:
100%

Steps to Reproduce:
Scenario A
1. qpid-config add queue vxc --argument qpid.max_count=10
2. ./qmf2_list_objects --query-data queue/vxc | ipython

Scenario B
1. qpid-config add topic test_topic_queue_parameters.aAxfiWds --argument "qpid.flow_stop_count=24" --argument "exchange=amq.fanout"
2. ./qmf2_list_objects --query-data topic/test_topic_queue_parameters.aAxfiWds | ipython

Actual results:
[A2]
{'_create_ts': 1395756222204641188L,
 '_delete_ts': 0,
 '_object_id': {'_agent_epoch': 2932,
                '_object_name': 'org.apache.qpid.broker:queue:vxc'},
 '_schema_id': {'_class_name': 'queue',
                '_hash': 'aee19387-3611-855a-c8ff-d2f106e5b5f4',
                '_package_name': 'org.apache.qpid.broker',
                '_type': '_data'},
 '_update_ts': 1395756224375230946L,
 'acquires': 0,
 'arguments': {'qpid.max_count': '10'},
 'autoDelete': False,
 'bindingCount': 1,
 'bindingCountHigh': 1,
 'bindingCountLow': 0,
 'byteDepth': 0,
 'byteFtdDepth': 0,
 'byteFtdDequeues': 0,
 'byteFtdEnqueues': 0,
 'bytePersistDequeues': 0,
 'bytePersistEnqueues': 0,
 'byteTotalDequeues': 0,
 'byteTotalEnqueues': 0,
 'byteTxnDequeues': 0,
 'byteTxnEnqueues': 0,
 'consumerCount': 0,
 'consumerCountHigh': 0,
 'consumerCountLow': 0,
 'discardsLvq': 0,
 'discardsOverflow': 0,
 'discardsPurge': 0,
 'discardsRing': 0,
 'discardsSubscriber': 0,
 'discardsTtl': 0,
 'durable': False,
 'exclusive': False,
 'flowStopped': False,
 'flowStoppedCount': 0,
 'messageLatencyAvg': 0,
 'messageLatencyCount': 0,
 'messageLatencyMax': 0,
 'messageLatencyMin': 0,
 'msgDepth': 0,
 'msgFtdDepth': 0,
 'msgFtdDequeues': 0,
 'msgFtdEnqueues': 0,
 'msgPersistDequeues': 0,
 'msgPersistEnqueues': 0,
 'msgTotalDequeues': 0,
 'msgTotalEnqueues': 0,
 'msgTxnDequeues': 0,
 'msgTxnEnqueues': 0,
 'name': 'vxc',
 'redirectPeer': None,
 'redirectSource': False,
 'releases': 0,
 'reroutes': 0,
 'unackedMessages': 0,
 'unackedMessagesHigh': 0,
 'unackedMessagesLow': 0,
 'vhostRef': {'_object_name': 'org.apache.qpid.broker:vhost:org.apache.qpid.broker:broker:amqp-broker,/'}}



[B2]
{'_create_ts': 1395756458407589948L,
 '_delete_ts': 0,
 '_object_id': {'_agent_epoch': 2933,
                '_object_name': 'org.apache.qpid.broker:topic:test_topic_queue_parameters.aAxfiWds'},
 '_schema_id': {'_class_name': 'topic',
                '_hash': '6182b36f-9f09-4118-2881-fb69e5355628',
                '_package_name': 'org.apache.qpid.broker',
                '_type': '_data'},
 '_update_ts': 1395756461943066990L,
 'durable': False,
 'exchangeRef': {'_object_name': 'org.apache.qpid.broker:exchange:amq.fanout'},
 'name': 'test_topic_queue_parameters.aAxfiWds',
 'properties': {'qpid.flow_stop_count': '24'}}


Expected results:
the value is provided as Int, thus printed by qmf2_list_object as int (without '')

Additional info:

Comment 2 Zdenek Kraus 2014-03-25 14:14:02 UTC
Created attachment 878479 [details]
patch proposal

Comment 3 Pavel Moravec 2014-07-30 12:44:38 UTC
Committed r1614637.

Comment 5 Valiantsina Hubeika 2014-10-20 19:14:52 UTC
verified on
qpid-tools-0.30-1.el6.noarch

Comment 8 errata-xmlrpc 2015-04-14 13:47:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.