Bug 1080489 - [RFE] dnf exits with an error when at least one srpm is present on the command line
[RFE] dnf exits with an error when at least one srpm is present on the comman...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-25 10:26 EDT by Jan Synacek
Modified: 2014-09-30 19:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2014-03-25 10:26:38 EDT
Description of problem:
dnf exits with an error when at least one srpm is present on the command line. I find yum's behavior a lot user friendlier - it just prints a warning and resumes installing the rest of the packages. It would be nice if dnf did something similar. The error is an overkill for that. There is no reason not to continue with the rest of the files.

I wasn't sure if I should mark this bugzilla as an RFE, but I did so. It's probably half RFE, half bug.


Version-Release number of selected component (if applicable):
dnf-0.4.18-1.fc21.noarch


Steps to Reproduce:
1. Put a few rpm files that you want to install/update in a directory.
2. Put a source rpm file there as well.
3. cd to that directory
4. dnf update ./*.rpm


Actual results:
# dnf update ./*.rpm
Resolving dependencies
--> Starting dependency resolution
---> Package numad.src 0.5-15.20140225git.fc21 will be installed
---> Package numad-debuginfo.x86_64 0.5-15.20140225git.fc21 will be installed
---> Package numad.x86_64 0.5-14.20140225git.fc21 will be upgraded
---> Package numad.x86_64 0.5-15.20140225git.fc21 will be an upgrade
--> Finished dependency resolution
Error: DNF will not install a source rpm package (numad-0.5-15.20140225git.fc21.src).


Expected results:
Something along the lines of what yum does:
# yum update ./*.rpm
Examining ./numad-0.5-15.20140225git.fc21.src.rpm: numad-0.5-15.20140225git.fc21.src
Cannot add package ./numad-0.5-15.20140225git.fc21.src.rpm to transaction. Not a compatible architecture: src
<snip>
Resolving Dependencies
--> Running transaction check
---> Package numad.x86_64 0:0.5-14.20140225git.fc21 will be updated
---> Package numad.x86_64 0:0.5-15.20140225git.fc21 will be an update
--> Finished Dependency Resolution
<snip>
Comment 1 Ales Kozumplik 2014-03-25 12:42:31 EDT
Hello,

thanks for the report. The behavior is intended one and will stay, I however updated the documentation to make it explicitly known, commit 53a7442.
Comment 2 Fedora Update System 2014-05-02 04:32:41 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 3 Fedora Update System 2014-05-02 17:05:15 EDT
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2014-05-28 08:10:33 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 5 Fedora Update System 2014-05-28 19:50:31 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-05-31 19:59:08 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.